Fresh install Lubuntu 22.04 live usb menu not accessible

I made an live usb disk with officila Lubuntu 22.04 daily build from a Ubuntu 22.04 computer with Ubuntu tool. I tried thied this Lubuntu live usb disk and booting work well on two different thinkpad computers. But when the destop loaded and all look good all menu with the mouse or touchpad is unresponsive. I can reach som menu with “tab” and “enter” key but it is random. I tried to create more disks from different computers but the reaction is the same. What do I make wrong. I can say I been making live usb disk for ubutnu, xubuntu and lubuntu for 15 years so I should know what I am making…

2 Likes

You may have already tried this, but if not, try plugging in an external mouse and see if that works. It’s possible the new Linux kernel in Lubuntu 22.04 isn’t working well with your touchpad.

If that doesn’t work, do a sha256sum test on the Lubuntu 22.04 ISO and make sure that your file isn’t damaged. A corrupted ISO can cause all sorts of weird problems.

If the ISO is good, too, try flashing it to a new USB flash drive and try again. The old flash drive might be damaged.

If the problem persists, please post what model of Thinkpad you’re using. This should help with further debugging.

4 Likes

Have you tried booting the live usb on different pc’s?
Also, try to use torrents, as they rarely, if ever, get corrupt.
I had a weird ubuntu 20.04.2 iso that didn’t want to boot with secure boot. Ever since I’ve been using torrents i haven’t had any problem booting or installing.

1 Like

Thank you for All advice. The only thing I not tried yet is old school USB Mouse. Model is t450s and e-135. I Will be back when i tried mouse