Em Dash ( — ) Isn't Avalialbe On Lubuntu


It seems that I can not find the Em Dash I tried everything in the Keyboard and Mouse Settings and I didn’t find anything.

Can I make a request at Lubuntu? I have an English (US) layout keyboard.

Thank you!

I suspect you actually want to ‘type’ one out from the keyboard.
(as opposed to just copy-paste from a browser to an editor).

The easiest way I know is to define a Compose key.

setxkbmap -option compose:rctrl
sets the Right-Alt key to ‘Compose’.

Whenever you want Em Dash, press Right-Alt,
then press the dash key three times (- - -).

To reset the keyboard for any mistakes, just use
setxkbmap -option
(without option name)

(Either way, the setting disappears after you logout,
to make it stick, you need an autostart entry).


Thank you! It works.

I found a list with Compose Keys here: https://lubuntu.me/tip-compose-key/

compose:ralt  Right Alt
compose:lwin  Left Win
compose:rwin  Right Win
compose:menu  Menu
compose:lctrl     Left Ctrl
compose:rctrl Right Ctrl
compose:caps Caps Lock
compose:paus Pause
compose:prsc PrtSc
compose:sclk Scroll Lock
1 Like

:laughing:That looks like how it was done with LXDE (before 20.04).

1 Like

I have a small issue @humpty :frowning:!

I can’t set this command — setxkbmap -option compose:ralt — by default. I have to use it every time I turn on my PC.

Can I do something about it?

Thank you!

I did it!

I navigated at Preferences > LXQt Settings > Session Settings > Autostart — there I clicked on the Add button and added this command setxkbmap -option compose:ralt at the Command form.

It works.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.