Dual virtual VNC

I’m attempting to run a setup like this

|---------| |---------|
| 3840 | | 1920 |
| x | | x |
| 2160 | | 1080 |
|---------| |---------|
Display1 Display2

Display1: Connected to physical port, Shared as VNC:0 and Xserver :0
Display2: virtual screen, shared as VNC:1 and Xserver :1

Ideally I’d like to run one session of Lubuntu on each Xserver

Currently I can get a single 4k setup or a really messed up dual screen setup (2 1024x768 sections in a 4k workspace).

How do I setup Xorg config and VNC to get this setup? I’m using the nvidia driver, but don’t mind switching to nouveau driver. I would appreciate any pointers or full answers :slight_smile: . If you need any other logs or configs, I can share them…

nvidia-xconfig --query-gpu-info
Number of GPUs: 1

GPU #0:
Name : NVIDIA GeForce GTX 1050 Ti
UUID : GPU-89b0140f-1c48-b512-bdbf-5700571e68df
PCI BusID : PCI:7:0:0

Number of Display Devices: 0

/etc/X11/xorg.conf.d/10-monitor.conf

Section “Monitor”
Identifier “Monitor0”
VendorName “Monitor Vendor”
ModelName “Monitor Model”
Option “LeftOf” “Monitor1”
#Modeline “1920x1080R” 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync
Modeline “1920x1080_60” 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
Modeline “3840x2160_60” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
Option “PreferredMode” “3840x2160_60”
Option “Position” “0 0”
Option “DPMS” “true”
EndSection
Section “Monitor”
Identifier “Monitor1”
VendorName “Monitor Vendor”
ModelName “Monitor Model”
#Modeline “1920x1080R” 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync
Modeline “1920x1080_60” 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
Modeline “3840x2160_60” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
Option “PreferredMode” “1920x1080_60”
Option “RightOf” “Monitor0”
Option “Position” “3840 0”
Option “DPMS” “true”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Option “UseEDID” “False”
#Option “Monitor0” “DFP-2”
#Option “Monitor1” “DFP-0”
Monitor “Monitor0”
Monitor “Monitor1”
DefaultDepth 24
Option “ExactModeTimingsDVI” “true”
#Option “ModeValidation” “NoVesaModes, NoXServerModes, NoPredefinedModes, NoEdidModes, NoUserModes”
Option “nvidiaXineramaInfoOrder” “DFP-2”
#Option “metamodes” “DFP-0: 1920x1080 {ViewPOrtIn=1920x1080, ViewPortOut=1920x1080+3840+0}, DFP-2: 3840x2160 {ViewPortIn=3840x2160, ViewPortOut=3840x2160+0+0}”
Option “metamodes” “DFP-0: 1920x1080 +3840+0, DFP-2: 3840x2160 +0+0”
Option “ConnectedMonitor” “DP-0, HDMI-0, DP-1, DVI-D-0”
SubSection “Display”
Viewport 0 0
Depth 24
Modes “1920x1080_60”
Modes “3840x2160_60”
Virtual 3840 2160
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 32
Modes “1920x1080_60”
Modes “3840x2160_60”
Virtual 3840 2160
EndSubSection
SubSection “Display”
Modes “1920x1080_60”
Modes “3840x2160_60”
Virtual 3840 2160
EndSubSection
Subsection “Display”
Virtual 3840 2160
EndSubsection
EndSection