Drag-n-drop from URL internet browser to the desktop does not work

Dragging the page URL from Firefox to deskotp doesn’t work on Lubuntu 24.04, even though the mouse cursor on indicates that it should work.

1 Like

It’s even more weird: it works sometimes.
The same problem exists with 22.04 LTS.

1 Like

It’s probably because it’s a Snap. I’d file a bug against Firefox.

1 Like

I registered the problem with Firefox version 125.0.2 (64 bit) and the same error occurs with Google Chrome version 126.0.6447, which was installed by the apt command. The error is probably not in the browser, as both work correctly on the Xubuntu operating system.

The Firefox Debian package is just a recipe to install the Snap. tl;dr you get the Snap no matter what.

As for Chrome, well, that’s a whole different story. Basically any problems with Chrome is a Google problem. They’re the only ones that maintain it.

Even if the error is not in the browser, it would still be good to start there to get as many eyes on it as possible and identify the solution quickly.


I can confirm this error for Firefox, Chromium and Opera.
Maybe it’s a bug of LXQt.

1 Like

Could be. If it is, it’s most likely to be an issue with the portal (something we didn’t need before Snaps/AppImages/Flatpaks). Could even be Qt itself.


cd ~/Desktop
touch example.desktop
featherpad example.desktop

Featherpad now opens the new file ‘example.desktop’. Write to this file

[Desktop Entry]

Save and close featherpad.

Now you have an adaptable link on your desktop. You can edit the Name and URL to be suitable to the desired webpage. For further links on the desktop you can copy and paste this file or create new ones by this method.

1 Like

-Tried with .deb (no snap, no xdg-desktop-portal), failed.
It’s not a snap issue.

-Tried 3 different browsers, failed,
It’s not a browser issue.

My opinion,
-It’s probably lxqt.
Either libfm-qt
or pcmanfm-qt that recieves the DND.

I couldn’t find anything on github, the nearest I got was

but at that stage the .desktop file already exists.

This bug is to do with DND not being able to create
the .desktop file in the Desktop folder.
(Wolf314 confirms that manually creating the .desktop
file works if the shortcut is opened).

So far I have found…

It works if the url is longer than it’s root domain
e.g www.somesite.com/index.html

But fails if it’s just the root domain.
e.g www.somesite.com

I don’t think it’s to do with folders or extensions,
www.somesite.com/ and www.debian.org also fails.


Assuming it’s an xdg-desktop-portal issue, I tried to install the one Xubuntu uses to no avail. I’m surprised it works anywhere at all. As far as I can tell from the documentation, the FileTransfer portal would need to be implemented, but as far as I can tell, none of the installed portals (lxqt, gtk, kde, nor the added xapp one Xubuntu uses) implement this.

Of course, it also might not be a portal bug. I think, again, that filing a bug against Firefox is likely to draw the most attention to it.

Ok, so it’s not the portal. Same problem even with the Firefox Debian package from Mozilla.

If you do the drag and drop and select “copy here,” an error is produced that relates to comparing the size of the source and destination file. That kind of makes sense. tl;dr, I think it’s simple enough to say that pcmanfm-qt doesn’t implement this behavior. The question remains as to whether or not they want or intend to.

1 Like

The question remains whether they are aware of this error.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.