Dist-upgrade from 22.04 LTS to 23.04, lost audio/sound

Recently I upgraded my kid’s PC running Lubuntu 22.04 LTS, to Lubuntu 23.04, predominantly to benefit from support of pipewire, that I was hoping would solve the problem of not being able to use bluetooth headsets with the PC. However, after the upgrade, I am facing issues with the audio-subsystem i.e. where-in applications that produce sound (like web-browser or VLC) do not seem to find suitable audio device, or even if they do (after some tinkering to reinstall pipewire, restarting etc.) I find no sound coming out of the wired headphones. Tried changing headphones to be sure, but definitely do not get any audio. In fact, pavucontrol seems to believe that most of the device profiles are “unavailable” and that headset is not connected (while it is physically connected).

Looking for some help to get audio back on this. Here is a list of things that I have already tried:

  1. Initially I was facing this issue:
$ systemctl --user restart pipewire-session-manager
Failed to restart pipewire-session-manager.service: Unit pipewire-session-manager.service failed to load properly, please adjust/correct and reload service manager: File exists                                            
See user logs and 'systemctl --user status pipewire-session-manager.service' for details.
  1. So, I did the following:
$ sudo apt --reinstall install pipewire-media-session
$ systemctl --user restart pipewire-session-manager
$ systemctl --user restart pipewire pipewire-pulse
  1. Then some diagnostic commands:
$ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 223
Tile Size: 65472
User Name: bdutta
Host Name: kailash
Server Name: PulseAudio (on PipeWire 0.3.65)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
Default Source: alsa_input.usb-Sonix_Technology_Co.__Ltd._USB_2.0_Camera_SN0001-02.mono-fallback
Cookie: b4d7:4844

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC662 rev1 Alt Analog [ALC662 rev1 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Camera [USB 2.0 Camera], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ pacmd list-cards
No PulseAudio daemon running, or not running as session daemon.

$ pacmd list-modules
No PulseAudio daemon running, or not running as session daemon.

$ pulseaudio -k ; pulseaudio -D
E: [pulseaudio] main.c: Failed to kill daemon: No such process
  1. Output of alsamixer is as shown in attachment, surprisingly all controls seem to show mono, not stereo capabilities !

  2. Output of pavucontrol is as shown in attachment, surprisingly so many “unavailable” status seen:

I see the audio-input level-meter fluctuating where the audio-input i.e. microphone used is the one from my USB camera. However, the analog output through the wired headphone, doesn’t work – i.e. I hear no sound at all.

What can I do to troubleshoot and fix the issue ?

1 Like

For some reason the attachments aren’t showing up so I’m adding imgur links to the images:
Imgur link for alsamixer and pavucontrol

1 Like

Can anyone give me any clues of how to troubleshoot this further ?

1 Like

Lubuntu 22.04 had one supported upgrade path; to the next release or Lubuntu 22.10. There was no QA-tested or supported upgrade path direct from 22.04 to 23.04. I was tempted to post that when I first saw the post on the discourse, but opted to leave it & see if others responded (I’m not an expert in the sound changes; the only issues I experienced in QA were all resolved during development & thus no longer apply)

From your description - you chose an unsupported upgrade path; unless your upgrade involved a re-install & thus I misunderstood it. You may have issues our supported path does not have due to our work on ensuring clean upgrades using the supported path.

(this reply posted due to reference on reddit)

1 Like

Just a shot in the dark.
In your alsamixer pic, point to the 2nd column and press ‘M’ to unmute it. See if that helps.

Have you tried this?.

sudo touch /usr/share/pipewire/media-session.d/with-pulseaudio
sudo systemctl --user restart pipewire-session-manager
sudo reboot now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.