Disk not mounting

Im new to Lubuntu .My laptop has a Phison SSO256GTLC9-SBC-2.drive SSD of 256 gb where i installed the lubuntu . while installing i did manual partitioning of boot and swap and root. in gnome-disks it shows every partition is mounted, but if i try to open my SSD it shows the error . Path is not mounted. if i right click on SSD add choose mount , it says can’t mount file .i tried manually mounting boot , swap with swapon , root, didn’t work . reinstalled many time . i don’t know what is the problem

This was also asked at https://askubuntu.com/questions/1488293/disk-not-mounting

As I said on askubuntu

Just click on your user folder (amithm in Places) and you’ll go there, you can then click the / device at the top & be where you want to be I believe. You didn’t provide release details.



It’s not very clear what you’re trying to do.

That picture you put in your post is not from the installed Lubuntu system? That is from a LIVE USB session?

Are you trying to boot from that SSD now? The lsblk only printed sda device… is that the SSD?

What does it show when you run this:

fdisk -l /dev/sda

If the manual partitioning was done correctly, it would just boot… what is it showing when you boot? grub? Nothing?

Can you share screenshots for what you did during the install? Did the install actually complete successfully?

As Chris mentioned… can you please share which Lubuntu release you tried to install?


It’s not from the usb it’s from the installed system .my system has only 256 GB SSD nothing else .I created 512 for boot/efi ,12gb for swap and other 226 I think for root .
sda is my SSD

sda      8:0    0 238.5G  0 disk 
├─sda1   8:1    0   512M  0 part /boot/efi
├─sda2   8:2    0  11.7G  0 part [SWAP]
└─sda3   8:3    0 226.3G  0 part /var/snap/firefox/common/host-hunspell

Look at the mount of sda3
If I give df - h
It shows sda3 is mounted to /

this isn’t actually a problem, its just referencing your primary physical drive, hence in that view from your screenshot you have an additional icon, file system, that is on that physical drive and obviously does mount otherwise you wouldn’t be in a desktop to begin with. Use that (file system icon). PCmanfm has always been like that on whatever base I’ve used it on in that view, 2 icons for the primary drive, one you can use to see your file system, and one as a reference to a physical drive (which does have stuff you cannot look at directly, swap file/partition would be a good example). So, all the partitions are mounted on that drive. Not actually a problem, just a misunderstanding of what view is needed to see the contents of an actual partition that is mounted.


you’re not getting what i said (that icon that says “file system” is the kicker…). As this isn’t a lubuntu question but rather an lxqt query (the lubuntu team use lxqt, they didn’t write it or develop it), I suggest you shoot the lxqt folks a question. Here’s a link to their site:

1 Like

Ok thanks.let me seee