Discover only opens some of the time

Actually, Discover works, but only once, I have a similar problem, I open Discover, user it, I close it, open it again it doesn’t open, UNLESS, I reboot, did to reinstall, repair, etc and nothing worked.

What Lubuntu version? If you run it in terminal, does it provide any output?

4 Likes

Yes, I forgot to mention, the Lubuntu version: 24.04 LTS (Noble Numbat).

Ok, if I run Discover the first time from terminal this is what I get:

plasma-discover
fetch ratings! false
adding empty sources model QStandardItemModel(0x5e9a8a3445d0)
org.kde.plasma.libdiscover: Couldn't find the backend:  "kns-backend" among ("packagekit-backend", "snap-backend", "kns-backend", "fwupd-backend")
kf.kirigami: Failed to find a Kirigami platform plugin
qrc:/qml/Feedback.qml:2:1: module "org.kde.userfeedback" is not installed
no component found for "com.ubuntu.ubuntu"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"

After closing it and re-opening this is what I get: (and Discover doesn’t open)

plasma-discover
fetch ratings! false
adding empty sources model QStandardItemModel(0x5f52f8f8a580)

Note that I have re-installed it and also performed the suggested solutions on a different thread.

Thanks

I’m having the same problem with the same version of Lubuntu.

Here’s my slightly different Terminal output:

First-time opens:

fetch ratings! false
adding empty sources model QStandardItemModel(0x605a9d2a4c60)
kf.kirigami: Failed to find a Kirigami platform plugin
QObject::startTimer: Timers cannot have negative intervals
no component found for "com.ubuntu.ubuntu"
took really long to fetch KNSBackend(0x605a9d2ee950, name = "/usr/share/knsrcfiles/plasmoids.knsrc")
took really long to fetch KNSBackend(0x605a9d2ef750, name = "/usr/share/knsrcfiles/window-decorations.knsrc")
took really long to fetch KNSBackend(0x605a9d2fd5d0, name = "/usr/share/knsrcfiles/colorschemes.knsrc")
took really long to fetch KNSBackend(0x605a9d309b00, name = "/usr/share/knsrcfiles/lookandfeel.knsrc")
took really long to fetch KNSBackend(0x605a9d303510, name = "/usr/share/knsrcfiles/krunner.knsrc")
took really long to fetch KNSBackend(0x605a9d30b300, name = "/usr/share/knsrcfiles/kwinscripts.knsrc")
took really long to fetch KNSBackend(0x605a9d30c5b0, name = "/usr/share/knsrcfiles/kfontinst.knsrc")
took really long to fetch KNSBackend(0x605a9d312d60, name = "/usr/share/knsrcfiles/wallpaper.knsrc")
took really long to fetch KNSBackend(0x605a9d30cfd0, name = "/usr/share/knsrcfiles/icons.knsrc")
took really long to fetch KNSBackend(0x605a9d3194c0, name = "/usr/share/knsrcfiles/plasma-themes.knsrc")
took really long to fetch KNSBackend(0x605a9d323450, name = "/usr/share/knsrcfiles/kwineffect.knsrc")
took really long to fetch KNSBackend(0x605a9d321360, name = "/usr/share/knsrcfiles/systemmonitor-faces.knsrc")
took really long to fetch KNSBackend(0x605a9d31a8a0, name = "/usr/share/knsrcfiles/wallpaperplugin.knsrc")
took really long to fetch KNSBackend(0x605a9d31c5f0, name = "/usr/share/knsrcfiles/wallpaper-mobile.knsrc")
took really long to fetch KNSBackend(0x605a9d31ea90, name = "/usr/share/knsrcfiles/ksplash.knsrc")
took really long to fetch KNSBackend(0x605a9d32c800, name = "/usr/share/knsrcfiles/sddmtheme.knsrc")
took really long to fetch KNSBackend(0x605a9d332090, name = "/usr/share/knsrcfiles/kwinswitcher.knsrc")
took really long to fetch KNSBackend(0x605a9d330610, name = "/usr/share/knsrcfiles/aurorae.knsrc")
took really long to fetch KNSBackend(0x605a9d2fa270, name = "/usr/share/knsrcfiles/systemmonitor-presets.knsrc")
took really long to fetch KNSBackend(0x605a9d321b70, name = "/usr/share/knsrcfiles/xcursor.knsrc")
took really long to fetch KNSBackend(0x605a9d3436f0, name = "/usr/share/knsrcfiles/gtk_themes.knsrc")
took really long to fetch KNSBackend(0x605a9d341860, name = "/usr/share/knsrcfiles/plasma-systemmonitor.knsrc")
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/BasicListItem.qml:288:18: QML QQuickItem*: Binding loop detected for property "implicitWidth"
took really long to fetch FwupdBackend(0x605a9d2bd8a0)
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:200:9: QML MouseArea: Binding loop detected for property "implicitHeight"

Next time opens:

fetch ratings! false
adding empty sources model QStandardItemModel(0x59b8d88412b0)

[Hangs, doesn’t open]

1 Like

This text is a little difficult to unravel. Are you saying you needed to reinstall to get it to work? Or was a reboot sufficient?

Meaning dpkg-reconfigure? Or removing the files in ~/.cache?

I will say that while I can’t reproduce this, I generally try to reproduce bugs on fresh installations to remove variables. However, I do find a bug that also involves the GUI not loading that doesn’t seem to be reproducible in fresh systems. I would do the tests there and see if you can get Discover to load repeatedly using only one backend at a time. Similarly, you should get it to fail (I imagine even if you do it only once) by loading multiple backends, but pay attention to the comment that seems to suggest the order matters. If you can reproduce all that, I would mark the bug as affecting you, too, and leaving a comment about the nature of your system like the last commenter.

I just did some more extensive testing of this and it takes a lot to get it to happen. It’s a tricky one, for sure. But it’s there. That bug has an SRU template, meaning that someone is apparently working on a fix for 24.04.

1 Like

Yes, tricky indeed, also, this is a fresh install.
So far, the “fix” is to reboot.

1 Like