Discover and Discover's Preferences (KDE Preferences) page have no text displayed

Hi, i just upgraded to Lubuntu 24.04. Everything seems ok except that
Discover and Discover’s Preferences (KDE System Settings) page have no text displayed… (maybe something related to QML or QtQuick… or maybe even translations related)

Anyone has a clue on this?

Nope. I’d probably try swapping to English and see if that somehow doesn’t help.

For what it’s worth, upgrades to Noble aren’t really supported yet (at least not the LTS ones), so if you did really upgrade as opposed to doing a new installation, that may be related.

2 Likes

As a followup, I just did a Jammy → Mantic upgrade followed by an upgrade to Noble. I opened Discover and everything looks fine for me.

2 Likes

Nop… It’s not that, apparently!
i changed to english and KDE System Settings along with Discover is still blank. :frowning:

maybe i’m missing some package or something…

I think I might have figured out a possible solution.

I noticed this post on the Manjaro forums describing a similar issue and they essentially wiped the cache:

To be clear what’s going on, first, you need to understand what the ~/.cache folder is. According to the Freedesktop/XDG specifications, this is the default for $XDG_CACHE_HOME which is defined as " the base directory relative to which user-specific non-essential data files should be stored." The important thing to note here is that it’s a place where non-essential data is stored, meaning that it can be deleted without any real consequence. This post generally agrees with this idea.

So to be clear on what the solution was, they say they fixed it by doing mv ~/.cache ~/.cache.bak. This renames the first folder to the second. This is a lot like deleting the cache folder (indeed after this, unless some other program tries to access it, ~/.cache will not exist) except instead of deleting it, it just renames it. This can be useful if, for some really odd reason, some application has actually stored essential data there.

I hope this helps because otherwise, there are something like 300 bugs on the KDE bugtracker for Discover that include the word “text!”

2 Likes

Hi,

Thank you for your help and patience :slight_smile:

I’ve tried it but sadly it didn’t work either! I’ve also tried to reset some other parts as well (using backups so i could put it all back once it didn’t work).

This is not just on discover. System Settings (just the part related to KDE) ain’t showing any text either!!!

so it’s probably something related to KDE… some lib or something… i don’t know… :frowning:

This happened to me on the live 24.04 on a 12 year old pc.
Apparently, newer kernels do not work well with old intel graphic drivers (e.g i915). The fonts just show up blank.

This symptom shows up for both the the modesetting driver or legacy intel driver, it makes no difference.

If you can confirm you are using an old intel graphics card, I can post a temporary fix, but you may not like it.

3 Likes

Yes, it’s a very old computer… but if you’re going to suggest buying a new one i can tell you my employer is not going to accept it ahahah :stuck_out_tongue:

1 Like

What do you get if you enter
inxi -G
?

not sure if you’re ready to see it, but hold on to your chair cause here it goes (i mean, you asked for it):

Graphics:
  Device-1: Intel 82G33/G31 Express Integrated Graphics driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.11 driver: X: loaded: intel
    unloaded: fbdev,modesetting,vesa dri: i915 gpu: i915
    resolution: 1440x900~60Hz
  API: EGL v: 1.4,1.5 drivers: i915,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.5 compat-v: 2.1 vendor: mesa v: 24.0.5-1ubuntu1
    renderer: i915 (: G33)

No, we’re not a museum in case you’re wondering

I have found this xorg conf setting thats brings back the fonts
for plasma-discover and the sddm login screen.

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "DRI" "1"
EndSection

I don’t know why it works, but I do know that it forces
mesa to render via LLVMpipe instead of the i915 driver.
(classic drivers were removed from mesa v22).

By default there is no conf file on a clean lubuntu install.
This makes xorg use the modesetting driver, (which internally
uses the intel driver).

So you will have to create it;
sudo featherpad /usr/share/X11/xorg.conf.d/20-intel.conf
Put in the contents above and save it.
logout
login

You may lose a bit of performance depending on whether you
had a real gpu or not (the mesa native drivers were always
faster than llvmpipe/which is a sort of gpu emulator/).

If things go wrong, CTRL-ALT-F3 and login,
sudo rm /usr/share/X11/xorg.conf.d/20-intel.conf
Then reboot.

3 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.