Desktop off centre + main menu missing

G’day Lubuntu Fans,

Just wondering if anyone could point me in the right direction in reference to resolving the following issue.
I installed Lubuntu 22.04 LTS on my old 10 year old HP Probook about 3 weeks ago and it hasn’t missed a beat. It’s been a perfect unit and with Lubuntu installed been running like a new machine (previously had MATE’ & XFCE based distro’s on it, but was getting a bit tired etc).

Apart from general updates in past several days, I’ve made no major changes to the system. However, when booting up a couple of mornings ago I noticed my desktop had seemingly moved off-centre and there was a margin added to the top and left of the view-point, of approximately 35-40 pixels (see screenshot image attached), and in addition my main menu had visually disappeared (activates with Super Key).

I have carried out various searches within the forum and elsewhere, but as yet not found any answers as to what may have caused this issue.

Therefore, I’m not making heads or tails of this issue and wondering if any of the wonderful folks in the Lubuntu Forums could offer up a solution to this one.

Any advice, tips or tricks, much appreciated.


I’d check you haven’t actually added extra panels to your desktop…

When added, they are empty, and thus appear as the background color just as your bottom panel with nothing on them, until you alter their appearance, add widgets to them etc.

I’ll suggest moving your pointer over one of the edges & right-click to see if a panel menu appears. If it does appear, you’ll have options such as

  • Configure Panel
  • Manage Widgets
  • Add New Panel
  • Remove Panel
  • Lock this Panel

Note those options are what appears on my Lubuntu noble system, I’ve not booted a jammy system to check out how it appears on your system, let alone you’ve not mentioned if you’re using the original LXQt 22.04 came with, or you’ve updated it via backports

If you don’t want them, just remove them. If you did add them for a purpose, go into configuration and uncheck the Reserve space on display, or Auto-hide etc.

This is my guess anyway, and G’day :slight_smile:

1 Like

Hey guiverc,

Many thanks for that. You were right on the money - problem solved!

One ponders, how on Earth I added two empty panels to my desktop unknowingly, I’ll never know. Anyway, the issue is fortunately now solved.

Once again, many thanks for your efforts and solution in resolving this issue and Merry Christmas.


1 Like

I know about the issue, as I’ve done it myself. Be it phone distraction, call from elsewhere in office/home, or even knock from family dog wanting attention (thus unintended mouse click/movement) it doesn’t matter, as long as we achieve what we want/need.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.