Dependency resolution failed

I have tried to install a .deb package in my lubuntu 20.04 and it says “dependency resolution failed” in discover. I am not sure whether it has problem in the package or I have missed something.
What can i do to install the package?

I personally would use a terminal to try and install the package (sudo dpkg -i path/filename.deb) as in the terminal you can see the messages appear on the screen, rather than have to hunt for them in logs.

Then you can explore the issues using a browser ( or via command (apt-cache) to see if it was packaged for another release, another OS (debian etc) which is the usual problem (ie. a source has been added that doesn’t match your installed system)

(FYI: logs are likely found in /var/log/apt/history.log)

1 Like

You can also use sudo apt install ./Downloads/foo.deb to install a downloaded package.


Ok, I tried the dpkg process but it says ‘dependency problems prevent configuration of .DEB’ and ‘error processing package FILE’. Then I tried ‘apply full upgrade’ and it instructed me to apply apt-get install -f. And after doing that I did not find the package installed. I thought that it was installed but it was not.
any idea what to do now?

apt-ghettos apt install was easier (apt is a front end for dpkg that can deal with required dependencies where as dpkg requires them all to be provided or pre-installed; my habit is to use dpkg first so I can see what is required & re-evaluate my add if it’s too heavy; I often use apt if I’m happy too).

We cannot see the messages; it’s those messages that I mentioned before that I’d use to look up via web site ( or search via command to check they’re available, or if not why they aren’t available (ie. is package intended for another release? or another distribution?). For us to help we need the messages.

Ok, I have searched the site you mentioned but it is not there. Then I again searched the main site from where I downloaded the .deb package and it was for ubuntu. So I expect it to work with my lubuntu too as it’s an official flavour of ubuntu.

No, sorry you misunderstood.

You use the site I provided with detail from the dependency messages I cannot see.

For us to help you, we (or at least I need) the messages you are getting, where the packages (not found packages) are used to check why they conditions are not met (are they not there? a huge clue, or are version match issues the problem? another clue…)

It’ll be easiest if you paste the install command, plus output here, so we can read your issue & explore the requirements.

So here is the beginning of the issue
dpkg: dependency problems prevent configuration of (PKG)
(PKG) depends on libssl1.0.0; however:
Package libssl1.0.0 is not installed.
(PKG) depends on gstreamer1.0-plugins-ugly; however:
Package gstreamer1.0-plugins-ugly is not installed.
(PKG) depends on gstreamer1.0-libav; however:
Package gstreamer1.0-lubav is not installed.
dpkg: error processing package (PKG) (–install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.24-1ubuntu2) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Errors were encountered while processing:

After that I tried sudo apt -get install -f. I give y command to download additional files necessary. At the end, I did not find the (PKG) installed. Did I miss anything?

Picking two

shows the package is available for all releases, so I’d likely apt-cache policy gstreamer1.0-plugins-ugly to see if that is detected, or you have an issue with your sources (Lubuntu has ‘universe’ enabled by default so it should be found).

The other I looked at shows it’s only available for bionic (18.04) & prior releases, and you didn’t provide the package name (I asked for command), so I suspect the package was built for bionic or older, not focal (20.04). At this point I’d explore the unnamed package, where it came from, and if there was a later build of it…

I only quickly looked at those two.

Ok you got me. The package name is viber. I went to their website and downloaded the package naming ubuntu. At first I tried it directly through discover but showed dependency issues failed. Then you suggested dpkg process and I tried that. But I recall that dpkg process was successful when I used ubuntu.

I don’t know the program/app, however

refers to the snap being available

That would likely be where I’d try next, as introducing bionic packages to your system creates problems done the road and thus is to be avoided (I noted a -dev package that may meet a requirement but I didn’t evaluate potential pitfalls/problems).

1 Like

It’s an cross platform messaging app. Yes, you are right again about snap. But I didn’t try that snap package because it’s unofficial . Also the version is old . So I preferred the official deb package over it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.