Create shortcut to a remote file

I have a simple question:

how do I create a shortcut to a file (or folder) that exists on a remote (LAN) windows share?

i’ve tried using the Symbolic Link, but it does not work (apparently, from what i understand, this was supposed to be used just for folders and not for files, but folders don’t work either).

so… am i missing something?

So I haven’t actually connected to a Windows share on Lubuntu yet but I took a look at the manual and maybe all you need to do is drag and drop from the file manager GUI (i.e PCManFM-Qt):

I haven’t been able to test this myself since I don’t have this kinda setup and I don’t know if the share shows up there at all (I assume it does). If it does, you can try that and see what happens…

Sorry I can’t help on the terminal-side. I honestly don’t know if this is even possible.


You can drag and drop a file or folder from a network share but will not be able to open same.

As far as I know (and what I use on my LAN ) is to bookmark the LAN folder in PCManFM-Qt. You can bookmark folders but not individual files. This works fine for me.

See and scroll down to “to add a bookmark”

Hope this helps - maybe someone else has a better solution.


@That_Random_Guy @leok thank you both for reply

@That_Random_Guy I already tried that and it didn’t work.
When i try to open the File or Folder it send an error that it failed with the file or folder path (which is correct by the way) printed in the error box.

So far bookmarks the folders in PCManFM, like @leok said, has been the half-solution used, but direct shortcuts from the desktop to files would be ideal and timesaving.

I’m not sure where to report this as a bug in LXQt or in Lubuntu… i was more inclined to LXQt.
Any suggestion?


I just tested this with Dolphin file manager (installed it to Lubuntu) and creating the shortcuts to the desktop work fine.
I think a bug should be filed on PCManFM-Qt - do you want to submit it or should I?


This needs to be tested more - what version of Lubuntu are you running?


Please, if you have the time submit it and post the link back here (if i’m not asking to much).
If you don’t have the time i’ll submit it myself ASAP (when i get some free time to do it…)

I’m using Lubuntu 21.04

Fine …I have the time and will test again etc etc and report back - thanks for posting!


It is I that have to THANK YOU!!! :smile:

1 Like

Filed the bug see:


Great! Thank you.

I wonder if this should also be reported on LXQt’s PCManFM-Qt GitHub or if this happens just in Lubuntu?

Any clue?

I usually confirm the bug on another system before I report upstream…

I have a Fedora 34, an OpenSuse tumbleweed, and Debian testing (bullseye) systems I keep updated for testing purposes (okay I actually use the Debian system), however sorry I can’t test as I don’t use SaMBa (I use NFS).

Me, I’d do what I normally do (create my shortcuts via terminal), test it works as I expect (using my normal NFS shares), then repeat using pcmanfm-qt using NFS. Then I’d replace the NFS with SaMBa/CIFS shares. (Note: I don’t have windows either so can’t test that).

ie. I’d gather as much info as you can, confirmation that it’s not Lubuntu specific… then file upstream (if it was confirmed to impact another OS). Note: I mentioned a few; they currently all have about the same software as Lubuntu hirsute (21.04) but at times some are ahead, others behind… except maybe tumbleweed

I maybe able to look at this in a few days, but currently I’ve taken little notice in this discussion (I noted @leok’s bug appear on #ubuntu-bugs-announce then remembered I’d seen mention of it on here earlier).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.