Can't see images

When people post their questions and include images, I can’t see them.

I’ll include a link to a screenshot.

Clicking on the image element doesn’t help.

I can’t even see the image in this very message - at least not in the preview panel on the right.

This may be related to a known issue, but I’ll let @teward confirm for sure.

1 Like

Ongoing CSP weirdness. Known issue, it’s why we’re in “Performance Issues” state on status.lubuntu.me.

Link to the actual question you’re seeing by the way so I can go and poke and test.

2 Likes

That looks like it. I seem to kinda recall when it came up in conversation.

Either way, the problem still exists.

This is a link that should go directly to the post:

I note that unlike this post which is an upload, your image is a link, @KGIII. Try uploading it instead. Even pasting it should do the trick.

I have no problem seeing the image in that post, by the way. It’s also an upload (maybe it wasn’t originally?)

I made it a link on purpose in my first post.

Edit: The pic should be the top-most line of this comment - but it’s not there for me. It may show for you folks.

The image didn’t show but when I did a ctrl+f5 on my end it restarted the connection and got updated headers. There may be a header caching problem going on somewhere, but that’s a bit harder to track.

1 Like

Here’s an upload example (all I did was open your image link, right click, copy, and then come over here and paste in the edit window):

Also: weird that I see one of your three images though none of them are uploads. It’s inconsistent.

If I go back to that original post, I can see it if I ctrl + f5.

Now it’s giving me some sort of error when I try to upload the file using the ‘add image’ function.

I’m attaching a random image. It’s a test.

I can’t see your first image or the third one, but I can see the second one. I can also see this last one which is unique in that it’s an upload.

1 Like

If I do the CTRL + F5 thing I can now see when folks upload an image.

So, until it gets fixed, I can just do that.

Looks like I found something: conflicting CSP policies!

I’ve gone and removed Discourse’s inbuilt Content-Security-Policy rules and handed that over to the ones we’re rolling ourselves.

This SHOULD fix the issues going forward. Simply close your browser and attempt to reopen on pages where they don’t work and see if the images work now.

3 Likes

I did so, the image still doesn’t show on the example link above.

But, curiously, all the images are showing in this thread. (Edit, not now.)

Pressing CTRL + F5 makes the image show in the example link.

So, maybe it’ll fix it in threads from here on out, but previous threads are still impacted? I don’t know - I did close and open the browser.

You know, lemme check something.

It shows just fine in Vivaldi and in Firefox. Not in Chrome or Chromium. They may have something in the cache, even though I restarted. I’ll clear cache and take a peak.

Worst case, the CTRL + F5 works for now, as do at least two other browsers. I have no extensions that should be causing it - nothing is blocked in uBlock, I even turned it off completely and checked.

That’s a caching problem, nuke your browser cache and keep going. I had the same problem due to ‘page caching’ headaches, and because there wasn’t any page content updates it didn’t pull a new header.

Short story, purge your cache and it should resolve it going forward.

4 Likes

Purging my cache didn’t help. Weirdly, it now works fine in incognito mode. I purged all my cache, everything, and even rebooted. I suspect Chromium is giving me the issues.

It now works fine in other browsers. So, there’s that. When I’d previously checked, it did not.

I tried Chromium with no ad blocking and no VPN. I deleted all the cache and rebooted.

So, I’m going to mark this as solved - as it works fine in other browsers and it previously didn’t. I’d checked that before asking. Chromium will eventually get it sorted out. It works just fine in incognito mode, so maybe it’s not removing the cache entirely. That’s not a Lubuntu problem, nor a Discourse problem.

Chrome has a similar problem, so it’s probably a Chrome/Chromium problem.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.