Can't install Lubuntu 20.04.3 LTS

Hey guys, I’m a total new about lubuntu and wanted to try it since it’s supposed to be the best distro for low end computers and I’ve been having trouble trying to install the OS.

First I tried installing 21.04 and everything worked great (from the USB) and after installing it, it didn’t boot or appear in the BIOS as a bootable option.
then I tried 20.04 LTS and now when I try to boot through the USB, it sends me to the GNU GRUB terminal, asking me to load the kernel and I don’t have the system installed, I can’t access the option to install o any kind of UI appears for me to enter Lubuntu and install the OS, just a terminal of grub.

My laptop is an Asus x55c and I used Balena Etcher to make the bootable USB, if you need to know the specs or other stuff. Thanks for the help in advanced

Well, I just checked and it isn’t the bootable HDD I made because it works with another laptop. I think it sends me to the GNU GRUB menu because i deleted EVERYTHING from the HDD on my laptop when I was on the Lubuntu 21.04 ISO trying to install it. I deleted everything because it wouldn’t appear on the boot options, it’d still say Pop! OS and not work. Did I damage my HDD?

I think it’s too early to tell if there’s any hardware failures.

When you ran the install did you select the Erase option in the beginning for both 21.04 and 20.04?

1 Like

Please enter the firmware settings (BIOS or UEFI) and make sure, that boot order lists USB devices first and the hard disk later.

Then boot the installation medium and open the terminal. And post here the complete input and output of:

sudo parted --list
sudo efibootmgr -v
1 Like

If you mean when i first installed it, yes. I chose replace partition because it was the only option working.

Then when trying to enter the boot from the 20.04 USB it just sends me to the GNU GRUB 2.04 menu

Things is, the only boot option is called “SATA PS: PIONEER DVD-RW DVRTD” and there’s no option for the HDD. I accidentally deleted the boot option because it wouldn’t change from Pop os, thinking I could add it again for Ubuntu or it would appear again after installation.

I got it to boot. I got into the BIOS, and forced the laptop to boot on the USB and BUM, terminal for entering Lubuntu appeared again, so I’m installing it now. If anything goes wrong, I’ll let you know and thank you for your help


Your machine is using BIOS or UEFI ?
You not wait use windows ? Convert to GPT and ceate a first partition 8 MB bios-grub and second ext2 500 MB … after create a root partition and if you wish another partition for home.

I already solved it. I just had to override the boot option from BIOS and i got to install the OS

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.