Can't get downloads to run? How do I do this?

<!-- I have an old 32 bit Dell Latitude that the OS crashed on. I installed a new hard drive with Lubuntu 18.04 32bit and performed the updates so no telling what it is now as the OS. After a few hours I was able to get connected to WiFi and get online. I am trying to install "Simultude" circuit simulation software. I have downloaded it as a file as a zip folder as an image, as an APP.......etc.... I have downloaded from Simultude and several Linux sites. What do I need to do to get Lubuntu to open and run a software file? I don't right code so this is all Greek to me. Surely I don't have to write OS code to run software to start learning to write code! I am wanting a circuit simultator, Arduino software, and possibly Pixstart to program some ICs. What do I need to do to get the Simultude to run? Does anyone have a download of Linux that already has these installed? Please make sure before you post, you have read the instructions! https://discourse.lubuntu.me/t/about-the-support-category

Welcome to Lubuntu’s discourse.

ZIP files are compressed archives, and need to be expanded to normal files for efficient use (though you can peek inside them using archive tools, and some software will use compressed images but it’ll be far slower).

I don’t know what “Simultude” is sorry, however if it’s source in the zip (or other form of tarball) you need to compile it to make use of it regardless of OS.

Compilation from source pre-dates microsoft windows, so you’ll do the same today as you did in the 1980s on DOS (pre-windows), or UNIX (generally GNU/Linux today). The OS being used doesn’t matter (though commands may vary slightly according to OS and maybe just the ‘\’ used by dos|windows and ‘/’ used by unix|posix|osx|linux).

If it’s not source inside the ZIP, as you didn’t provide link or details, we can’t know what to do. Usually tarballs or zips contain a README or set of install instructions inside, though not always, as the instructions can be located where you downloaded the tarball/zip file from, but we weren’t told that.

Somehow you are actually making the most sense that I have heard all day. I did not realize the antiquity of Linux. Anyways, I downloaded it every way possible. If it was a zip I tried to unzip it to desktop or unzip it then add it to desk top. I have absolutely no experience in Linux but am wanting to learn it. I like the open share idea. I have no clue what “tarball” is. I did try to get KDE Discover and Debian to work because it said that Discover was part of Debian?
I tried to get a screenshot or use a snipping tool but none of that works on here. I sincerely apologize for my total lack of knowledge on Linux. The file name is “SimulIDE_0.3.11-Lin64_OK” after it is unzipped.
Where do I get Apps or information to be able to run apps. I have the basic system working but no way to do anything with it.

Here is the address of the software. The download page shows the Linux download. https://www.simulide.com/p/basic-use.html

The page you provided mentions

Extract the contents of the compressed file you downloaded (.zip or .tar.gz).

The “.tar.gz” in that line is reference to a tarball, the tar or tarball being compressed with gzip thus .tar.gz. It’s just an older (1979) form of compressing files/directories for movement to tape than zip (1989) which does the same thing.

You don’t need to apologize for lack of knowedge, we all start somewhere.

When I clicked to download, I got the tarball (SimulIDE_0.3.12-SR8_Lin64.tar.gz)

I expanded it and looked to see

guiverc@d960-ubu2:~/Downloads$   file SimulIDE_0.3.12-SR8_Lin64
SimulIDE_0.3.12-SR8_Lin64: directory
guiverc@d960-ubu2:~$   cd Downloads/SimulIDE_0.3.12-SR8_Lin64/
/SimulIDE_0.3.12-SR8_Lin64$   ls -lah
total 0
drwxrwxr-x  4 guiverc guiverc   0 Aug 23 11:32 .
drwxr-xr-x 12 guiverc guiverc 20K Aug 23 11:32 ..
drwxrwxr-x  2 guiverc guiverc   0 Apr  4 14:33 bin
drwxrwxr-x  4 guiverc guiverc   0 Apr  4 14:33 share
guiverc@d960-ubu2:~/Downloads/SimulIDE_0.3.12-SR8_Lin64$   ls bin
simulide
guiverc@d960-ubu2:~/Downloads/SimulIDE_0.3.12-SR8_Lin64$   bin/simulide 
bin/simulide: error while loading shared libraries: libQt5SerialPort.so.5: cannot open shared object file: No such file or directory

The error I get though is prepared for on the page you provided though, as it reports

List of runtime dependencies is:

  • Qt5 Serialport

and provides a command to deal with that. I had a look, and my system had all requirements already installed except for that one

FYI: If it looks strange how I space out before my actual commands, I do that for commands I don’t want stored in my command history. The extra commands such as use of file were used for your benefit (ie. exploration; as I could see it was a directory during expansion)

Discover is the KDE Software Store, the KDE equivalent of GNOME Software. It’s included with modern Lubuntu (ie. 18.10 & later).

Your results will differ to me, as my Lubuntu is groovy (what will become 20.10), thus is LXQt (Qt being Qt5) and thus the Qt dependencies already existing (except the one). In contrast Lubuntu 18.04 uses LXDE which is GTK2, meaning you won’t have those dependencies, plus your system will use more memory to run them (as it’ll need the GTK2 libraries used by your desktop to be in memory, plus Qt5 libraries used by software). If your box is RAM limited, you may suffer a performance hit.

1 Like

I downloaded the zip file and then unzipped it on desktop. Where did you find the script that you posted and how does that tell me how to make it run? What do I need to do? A command on the “RUN” tab or right click and load it somehow?

I didn’t use a script.

guiverc@d960-ubu2:~/Downloads$

is my command prompt, the commands I use follow it.

eg. the command file SimulIDE_0.3.12-SR8_Lin64 I entered was to ask the system what type of file that is… it responded

SimulIDE_0.3.12-SR8_Lin64: directory

ie. it repeated the file name and a colon, then gave the type of file as “directory”.

Thus I cd (change directory) to it. Next I ls or list files in that directory (-lah is just me, -l long format, -a for all files including any hidden, and -h human format as I don’t like big numbers)

I can see two sub-directories, the ‘bin’ by convention (since the 1970s) means binaries, machine executable and not always human readable so I know whatever runs it will be in there… thus why I list files (ls) in that directory and it reports only a single file.

My final command was bin/simulide which executed the one binary there, which resulted in the error I mentioned.

As this is my primary box I didn’t go further (I’d use a test box first), but I mentioned the error and how it was covered in the documentation anyway (ie. my Lubuntu doesn’t include Qt5 Serialport which I think personally is understandable).

I suspected if I added the required library, that command would have executed it correctly, and I just followed the instructions provided on the page your provided me.

Executable is in “bin” folder, just double-click it or run from a terminal if you want to see some messages about SimulIDE execution.

(though to be honest I didn’t read that (quickly skimmed it), I explored the way I did more for your benefit as it’s more akin to what I’d actually do… explore & only read the instructions if I got stuck. I stopped skimming at the Don’t move or delete files as I could guess the rest)

I did see the Don’t move or delete files page. Sounds like Linux is old school file transfer programming. I skipped from Vax/Fortram to Windows. Nothing in between!
So if I go to the BIN folder and double click it will run?

How would I add it to desktop? Or make an executable file shortcut for it?

The download page indicates yes, and I see why not. Myself I’d use terminal (at least initially) so I can peruse messages & detect issues, and gain some clues on how it works but that’s just me.

For creating desktop icons, I’ll provide you the Lubuntu manual page reference (it assumes 20.04 or the latest version, but it’ll apply)

https://manual.lubuntu.me/stable/5/5.2/desktop_icons.html

Executable files are pretty much identical to any other OS (inc. VAX/VMS if I recall correctly), put your commands in a text file, make it executable (chmod +x or properties in a GUI file manager; dos & windows don’t need this step not having that execution security), and have it in your $PATH (searched paths for commands). DOS & windows also include the $PWD (present working directory, or current directory) where as all POSIX OSes don’t do that by default as it’s deemed safer not to (instead we use ‘./shortcut’ before the script ‘shortcut’ as ‘.’ is shorthand for the current directory, and the ‘/’ indicates it’s a directory; which works in dos/windows too anyway. microsoft copied much of what’s in DOS from the Xenix they tried to sell IBM before buying qDOS and licensing it to IBM). The other difference is POSIX uses shebangs (first line starting with a “#!”) to tell shell what interpreter is needed to execute it (the “#” makes it a comment anyway so its ignored if not understood). eg. the first line for a simple BASH (bourne again SHell script) is “#!/bin/bash” (as /bin/bash is where the binary bash is located, which you’ll see with the command whereis bash) Sorry if I’ve hidden the tiny bits you need it too much detail… that’s just me.

I’m sorry but you lost me and my head is spinning now. When I open in terminal it asks me if I am “root”? It is a small black screen with script waiting on a command.
I open the folder> go to bin and click on it> I see a desktop Icom of the program I want to run. When I double left click it it gives me a pop-up message that the folder is executable and asks if I want to execute. I click yes then nothing happens.

Sorry, I was hoping to have a play on a 18.04.5 system for you but haven’t got around to it.

I see no difference in how one script/batch/jcl/… works on one OS, to another. They are all just text files containing commands (the commands each has varies).

The file-system on which they are stored will differ, thus the requirement to mark a file as executable (something which cannot be done on FAT or NTFS thus it doesn’t apply in dos/windows) which was the reason for the chmod +x command I mentioned.

Some OSes make assumptions, eg. windows is very limited and makes large assumptions providing limited options (ie. it has a tiny set of commands allows). Unix & any POSIX compatible OS doesn’t have those limits allowing you to use any language you like, this however can lead to confusion and mistakes as many languages do look alike; to avoid these errors the use of a shebang was implemented. It’s the first line of the file, being in fact a comment meaning it’s ignored anyway when run on a system that can’t handle it… Refer https://en.wikipedia.org/wiki/Shebang_(Unix)

My plan was to boot into a recent QA-test install of 18.04.5 as indicated at the beginning of this post, but they’d already been wiped (with other flavors or Lubuntu groovy QA-test installs). I’ve actually attempted a Lubuntu 18.04.5 install just to assist you, but that led down a rabbit hole I didn’t expect…

I really appreciate all of the help. I have been doing some studying. Linux seems to be quite a bit like MS/DOS. I have some experience with that. I did see the files needed to run listed but am not certain about how to search for them on my machine. I did obtain a 40 most used commands list. I am guessing when I am asked if I am root in terminal mode it wants to see “sudo” in front of my command. I think if I learn how to ensure that I have the files needed listed then learn to install them I will have this beat. It appears that just learning the commands and were to use them is my biggest battle. Are they entered in the run box? If opened in terminal will changes occur in the OS or just tested in terminal? Thank you for all of the help and advice.

sudo elevates your privileges for the command that follows it, eg.

guiverc@d960-ubu2:~/favorites$   whoami; sudo whoami
guiverc
root
guiverc@d960-ubu2:~/favorites$   echo $UID; sudo echo $UID
1000
1000

You can think of sudo as super user do (or switch user do where the default user is root unless you specify one; and we usually don’t provide an specific user)

I always opt to open a terminal, usually with Ctrl+Alt+T as it’s quick & my fingers know it.

Commands impact your system, the impact though can vary. Some effects will occur instantly, others require you to reload your terminal (ie. it’ll impact all newly opened terminals, but to see impact in your existing terminal it’ll require closing & re-opening). Some will take effect next login, or next restart of the service (next boot commonly for windows users, *nix users usually restart services by commands and don’t just reboot). Some commands have no impact (just show detail such as the whoami I used as example)

*nix commands also often give no results for success (ie. if you cmp or compare files, no output is given if the files are identical). This can be a little bit terse to people used to windows or ms/dos which will say “Files compare ok” instead of giving no output. Just a different approach (the *nix way just makes it easier to script/automate things…)

So you asked it to identify you and it answered. Was that in terminal mode or in run box? What command would list files that I would like to see if they exist? Will it give a list like on websites stating what is needed?

It would have been in a terminal on workspace 1. I always have a terminal open bottom left (usually with a couple of tabs open).

I had cd (change directory) to favorites (my favorite ogg & mp3 music) so I could cp & then cmp and diff the original & copy of the file for pasting, I didn’t use it though.

I’m not sure what you’re asking here sorry. My mind has gone to apt-cache show which will reveal details of a package you can get from the web site https://packages.ubuntu.com/ , but I was reminded of a ~recent answer I gave to a query on IRC. You possibly meant more along the lines of stat, file or something else, but sorry it’s unclear to me.

Thank you for all of the help and getting me started. I am certain that I will have many many more questions but you definitely got me on the right track and in the right frame of thinking on this. You are the MAN!

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.