Can't enable wifi Lubuntu 20.04.1

Hello everyone. I am a new user of Lubuntu and have an All-in-one EXO W8 18. I’m not well experienced in Linux OS but I’m always doing some research. My problem today is I can’t enable Wi-FI using nmtray. Eveytime I try to enable the option it just does nothing at all. Right now I’m using USB Tethering so I can write this topic. Here’s some info I gathered.

https://pastebin.com/tAdPEjU3

Hello,

Thank you for showing us that info. Think it’ll help get people started at trying to crack this one out.

From what I can see, the driver is installed and it’s showing up as a module. Only weird thing is that both ifconfig and iwconfig say the interface is down.

Can I ask how you got the driver installed? Did you use the GUI and or did you somehow get it via terminal with some commands? If the latter, could you maybe recall what command(s) you used?

Thank for your response!

Well, right before I installed Lubuntu I’ve noticed this issue. I thought that I could solve it only rebooting the system because when I was installing the OS I had WiFi, but it didn’t work. So I went to check if LXQt desktop could help me with something and it actually did because the WiFi Network connected automatically and without problem. Furthermore I started searching the web and I found this topic. After doing what is mentioned there and rebooting a window pop up saying I needed to update some stuff on the system (I believe it was a regular update, or at least that’s what it seemed to) so I said ‘yes’ and it started updating. Later, when the update process was over I rebooted the system one more time and that’s when the problem started again.

From your logs at pastebin:

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes

Do you have a switch or a function key to enable wifi? Please give it a try.

2 Likes

I found something similar to your problem where a person showed similar output to yours:

Since Lubuntu/Ubuntu are basically based on Debian, this resource can give us a starting point on understanding what can be done to fix it.

The answer this person accepted is kinda unclear since as you have also shown, the module looks to be in place and loaded. That would suggest the driver should work provided it actually works…

The other suggestion the answer included was for a Github resource I found before finding that answer. Apparently someone hosts a repo for an updated driver for your NIC/WiFi card and while it was mentioned—and even though it’s been tested for—I don’t know if it makes sense long term since updates might eventually break it should it get reverted to what you have now. Also it’s a lengthy read but it could be something to look at.

I would try the recommendation from @arsivci though and see if there’s a physical switch you can enable/disable.

2 Likes

Though at times hard blocks can be caused by driver issues, by far, the two most common causes in order are:

  1. A physical switch or button on the device
  2. Disabling wifi in BIOS

Start there and then we can explore the more obscure things.

Yes. I do have a switch at the side of my pc. When I used to have Windows I had to install Control AP II in order to make the switch work so it can show me a panel where I can enable/disable wifi. I thought I didn’t have to install it because at the beginning the wifi was working “ok”. So I tried downloading Wine so I can run the .exe but now I have another problem. Whenever a try to execute Control AP II, Wine pops up an error saying “There is no Windows program configured to open this type of file”

Is there a way via terminal I can enable wifi network without using the switch or Control AP II?

I am not sure that WINE is going to do the trick for you. Maybe. I’ve never tried to use it for executing software that interacts with hardware that isn’t commonplace (i.e. CPU, GPU, memory, storage, etc.). While it seems possible (WINE essentially converts Windows-native requests to the kernel into Linux-native ones), I think it’s unlikely. A lot of WINE’s work is reverse engineering based on a lack of documentation or due to poor documentation from Microsoft and that is a path fraught with difficulty. Add to that the fact that “Control AP” isn’t even listed in the WINE App Database and you got a big problem.

That said, maybe we should figure out what this software does first. If we can do that, maybe we can figure out a way to do this in Linux natively. Unfortunately, I just get a bunch of garbage. Apparently it’s developed by “OEM?” Huh?

Anyways, normally a hard block means exactly that: it’s a hard block. It’s something that you cannot use software to unblock. The exceptions I have seen are:

  1. BIOS (did you check? If not, you should, and you should look very, very carefully)
  2. Driver incompatibilities causing inconsistent behavior. You can give us the results of lspci -nnk -d 10ec:8176 to figure that one out but if the last line “kernel modules” has only one entry, then it’s likely a non-issue.

Yes, the software is developed by OEM and after trying and doing some research I gave up with Wine trying to execute Control AP.

  1. I’ve already checked the BIOS and there’s nothing about network nor wifi network.
  2. This is the output:

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8175]
Kernel driver in use: rtl8192ce
Kernel modules: rtl8192ce

    (How much screwed am I?)

I must say after days of struggling with this I wanted to go back to Windows 7 and now I’m trying to make a Windows USB bootable but it has been a total pain the ***.

1 Like

After following the instructions listed here with some variatons (instead of using “sudo dkms install 8192cu/1.8” I used “sudo dkms install 8192cu/1.11”) the option to Enable Wifi in nmtray is now operable, it can go on and off but no wifi near is showed. So… it still not working. Also, when I try the command “rfkill list” to check if it’s still hard blocked the command simply does nothing. Why rfkill is not working?

1 Like

after running command: sudo lshw -c Network

*-network UNCLAIMED
description: Network controller
product: RTL8188CE 802.11b/g/n WiFi Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: ioport:e000(size=256) memory:f7200000-f7203fff
*-network
description: Ethernet interface
product: JMC250 PCI Express Gigabit Ethernet Controller
vendor: JMicron Technology Corp.
physical id: 0.5
bus info: pci@0000:02:00.5
logical name: enp2s0f5
version: 03
serial: 80:ee:73:43:31:a2
size: 10Mbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msix msi bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:35 memory:f7d00000-f7d03fff ioport:d100(size=128) ioport:d000(size=256)
*-network
description: Ethernet interface
physical id: 4
bus info: usb@3:1
logical name: usb0
serial: 92:04:29:b9:7b:cb
capabilities: ethernet physical
configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.20 link=yes multicast=yes

What does UNCLAIMED mean?

You just installed a deprecated driver, which is probably not a great idea.

I would get to work at undoing that. sudo rm /etc/modprobe.d/blacklist-native-rtl8192.conf && sudo dkms remove 8192cu/1.11 should do the trick.

That should resolve any other issues you were having, including the one with rfkill.

For future reference, I wouldn’t blindly type in things you find on the Internet unless someone is specifically working with you to fix a problem you are having.

After you’re back to where you started, look again at that GitHub repository for the troubleshooting suggestions they have.

2 Likes

Hello, I just joined this topic because I installed 20.04.1 on my 1st gen Surface Go and can’t enable wifi. I ran wireless info script which generated a wireless -info.txt file which identified my wireless network. How do I post it to pastebin so that you can help me understand how to connect to my wifi? Thank you.

@Dano create a new topic, please.

Thank you for your quick reply; how do I do that?

  1. Click here: #support
  2. Click the “New Topic” button at the top right
  3. Note that some of the reply area is filled in with a link to instructions. Make sure to read them before replying.

This is a very common issue with RTL series wifi card. You can refer to this topic for the solution.
https://discourse.lubuntu.me/t/help-wifi-adapter-rtl8822be-not-working-with-20-10/2048

However, with each kernel update, you have to do the steps again. The ultimate solution which I am using is to change a laptop with Intel wireless card.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.