Cant download from Discover (software center)

When I try to download software from discover, it asks me for my password. Once i type it in I get a messege “you have no authorization to execute this operation”. I’m the main user on the computer and have sudo status.

Can you please provide what version of Lubuntu you’re using and or supply the output to the command—

uname -a

—run via terminal. You can just copy/paste the text here. :slight_smile:

Something must be amiss with the way you have configured your user. Or maybe the wrong password or something. If you run plasma-discover in the terminal, does it produce any useful output?

Linux x-pc 5.0.0-15-generic #16-Ubuntu SMP Mon May 6 17:41:33 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

adding empty sources model QStandardItemModel(0x56140e3bcd30)
no packages for "libgphoto2"
no packages for "libu2f-udev"
no packages for "cockpit.desktop"
no packages for "org.cockpit_project.cockpit"
no packages for "im.riot.webapp"
could not find "inkscape.desktop" ""
could not find "org.kde.development" ""
could not find "inkscape.desktop" ""
could not find "org.kde.development" ""
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/libexec/kf5/klauncher'
kdeinit5: Launched KLauncher, pid = 2208, result = 0
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kdeinit5: opened connection to :0
kdeinit5: Got EXEC_NEW '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/http.so' from launcher.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/http.so'
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
kdeinit5: Got EXEC_NEW '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/file.so' from launcher.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/file.so'
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
kdeinit5: Got EXEC_NEW '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/http.so' from launcher.
kdeinit5: preparing to launch '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/http.so'
kf5.kio.kio_http: Can't communicate with kded_kcookiejar!
kf5.kio.kio_http: Can't communicate with kded_kcookiejar!
could not find "inkscape.desktop" ""
could not find "org.kde.development" ""
no packages for "libgphoto2"
no packages for "libu2f-udev"
no packages for "cockpit.desktop"
no packages for "org.cockpit_project.cockpit"
no packages for "im.riot.webapp"
could not find "inkscape.desktop" ""
could not find "org.kde.development" ""
kdeinit5: PID 2219 terminated.
kdeinit5: PID 2229 terminated.
kdeinit5: PID 2231 terminated.
PackageKit stopped running!
could not find "inkscape.desktop" ""
could not find "org.kde.development" ""
could not find "inkscape.desktop" ""
could not find "org.kde.development" ""
qrc:/qml/ApplicationsListPage.qml:144:16: QML ResourcesProxyModel: Binding loop detected for property "sortOrder"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/Page.qml:282: TypeError: Cannot read property 'globalToolBar' of null
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
"Could not convert argument 0 at"
         "expression for iconName@qrc:/qml/KirigamiActionBridge.qml:35"
"Passing incompatible arguments to C++ functions from JavaScript is dangerous and deprecated."
"This will throw a JavaScript TypeError in future releases of Qt!"
qrc:/qml/KirigamiActionBridge.qml:34:5: Unable to assign [undefined] to QString
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
QObject::startTimer: Timers cannot be started from another thread
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusWait among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusWait among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusWait among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusSetup among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusLoadingCache among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
Status not present PackageKit::Transaction::StatusLoadingCache among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 0
Status not present PackageKit::Transaction::StatusLoadingCache among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 100
Status not present PackageKit::Transaction::StatusLoadingCache among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 0
Status not present PackageKit::Transaction::StatusLoadingCache among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
Status not present PackageKit::Transaction::StatusLoadingCache among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 100
Status not present PackageKit::Transaction::StatusQuery among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 100
Status not present PackageKit::Transaction::StatusRunning among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 100
Status not present PackageKit::Transaction::StatusLoadingCache among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 100
Status not present PackageKit::Transaction::StatusFinished among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 100
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusWait among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusWait among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusWaitingForAuth among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
percentage cannot be calculated
Status not present PackageKit::Transaction::StatusWaitingForAuth among (PackageKit::Transaction::StatusRemove, PackageKit::Transaction::StatusDownload, PackageKit::Transaction::StatusInstall, PackageKit::Transaction::StatusUpdate) 50
PackageKit error: PackageKit::Transaction::ErrorNotAuthorized "You have no authorization to execute this operation" "Failed to obtain authentication."

Is this 19.04 or 19.10?

With the kernel that is posted I am thinking it is 19.10.

Actually, 19.04 has the same kernel.

Actually which package are we trying to install here?

the command lsb_release -r got Release: 19.04

I’m trying to install a game and chromium. Trying to install either give me the same error.

I am also facing this type of issue on my ASUS device. I am facing Asus Error Code 55. Please help me to fix this.

This is a hardware issue. Linux is wonderful, but it can’t fix broken.