Cannot install Vivaldi browser, nor Microsoft Teams, nor Opera

I can’t install the Vivaldi browser, nor Opera browser, nor Microsoft Teams on my Lubuntu 24.04 computer. Thankfully I was able to install the snap version of Opera, however nor Vivaldi nor Microsoft Teams has a snap installer. What might be the issue? I receive the error message displayed on the picture below:

It sounds like your system is missing a package dependency. So probably something that software you’re trying to add is needing something that isn’t on your system.

I can’t recall if that wizard you’re showing there is actually smart enough to figure out how to install those dependencies normally but my guess is if it’s showing that, then maybe not.

Can you click on the details tab and show us what it says there?

Unfortunately, this is a known issue with QApt. It’s been on version 3.0.5 for several years now so I don’t have a lot of hope that will get fixed.

Luckily, there’s numerous solutions such as:

  1. dpkg -i
  2. Discover

Neither of the .deb installer packages worked that I tried… This needs to be fixed in Lubuntu asap imo. Imagine a new Linux user trying out Lubuntu and encountering these installer issues, the user would be back on Windows in no time.

“Fixing it” would mean removing QApt, but we’re not the only flavor of Ubuntu that uses it. It still has a purpose, even if it has limitations.

For what it’s worth: Ubuntu/Canonical provides no guarantee that third party software works out of the box. That is up to the developer of the software.

That is the same with Windows/Microsoft.


How do I install a .deb package with dpkg -i? I read on the link you provided that all packages work by installing it with dpkg -i, I just don’t know how to use it…

Got it, open a terminal in the .deb file location, sudo dpkg -i vivaldi-stable_6.7.3329.39-1_amd64.deb and Vivaldi is installed :slight_smile:

Excellent news, now I am able to install .deb packages on my Lubuntu 24.04 :smiley:


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.