CamBam Key - Selection not Received

I use CamBam to produce GCode files for a CNC machine derived from a stl ( 3D model mesh file ).

In CamBam ‘ALT+mouse’ is supposed to initiate 3D scrolling.

Unfortunately, Lubuntu (Linux ?) uses the same key combination to move the window.

I have seen references to a work-around or key substitution that cures the problem.
Just need a hint on where to look.

Keep well,

This is tied to the OpenBox (the Window Manager used in Lubuntu) configuration. To change this I recommend copying the rc.xml file to the home directory (if it isn’t already there) and then making the edits you need. For example - cp /etc/xdg/xdg-Lubuntu/openbox/rc.xml ~/.config/openbox/rc.xml Once that is copied, open that file with your text editor of choice (Featherpad, vim and nano are all installed by default). The section you want to look for is in the <mouse> section, in particular anything that has "A-Left" (I count 3 mousebinds there). If you don’t need those you can simply delete them. This is a xml formatted file so indentation matters. When you are done editing, log out and log in again and it should respect your configuration change. If something goes wrong, you can simply copy that config file over again from /etc.
For more information, this is the OpenBox documentation.


Thanks for the prompt response, just the information I need.
I will delve into the suggested changes later this week.
Keep well, John.


Tried commenting out the ALT-Key combinations, and got an error message and no improvement in CamBam.
Will try again with your suggestion to simply delete the entries.
I need to better understand how config files work.


My reading of the rc.xml file tells me that the key ‘A-Left’ drags the window.

Digging around, found ~/.config/openbox/rc.xml and ~/.config/openbox/lubuntu-rc.xml.

Logic says the later version is the more likely to determine operation on my Lubuntu system.
Tried commenting out the ‘A-Left’ entries, then Shutdown/PowerOn.
No error messages.
Then open CamBam, but still no 3D scrolling, just the normal window drag.

So still confused and digging.

Which of the multiple rc.xml files actually determines the operation of a new session ?

Keep well,

Neither are there by default, but the rc.xml file is the only one that will work.


Went back to rc.xml and commented out a single key binding: Context “Frame”, mousebind “A-Left”, action “Drag”.

Reboot: get error message.
Open window: cannot drag, cannot re-size or close with the title (X).
Window File dropdown dialog allows termination.

CamBam: no 3D scroll.

I will have to improve my understanding of just how keybindings pass through the system to make any progress on this.
The search continues.


What does that comment look like?

Which one?

Doing this response was a total frustration with FeatherPad.
It is too smart to use as a simple text editor.
I will search for a straight dumb ASCII editor.

Used FeatherPad to generate a text file on the desktop with a view to it becoming my response to this thread.

Used FeatherPad to change the following mousebinding into a comment:

<!--<mousebind button="A-Left" action="Drag">
        <action name="Move"/>-->

Restart the computer, get the following error message:
OpenBox Syntax Error
One or more XML syntax errors were found
while parsing the Openbox configuration files.
See stdout for more information. The last error
seen was in file “/home/john/.config/openbox/
rec.xml” line 639, with message: Extra content at
the end of the document

Clear the error message and open windows:

  • cannot drag any window, or resize or close,
  • File dialog box allows Quit.

FeaterPad text file left open to receive further entries.

Open Lubuntu Discourse, and select this thread and <Reply:

  • cannot enter text into the Reply box, the text instead goes into the open FeatherPad text file.

Spent a long time trying to sort out a method of copying this content into the thread response, and failed.

Opened CamBam and tested the “A-Left” scroll function without success.
There could be an issue with Cambam.

Went back to home/.config/openbox/rc.xml and removed the added comments.


  • no error message,
  • everything back to normal,
  • CamBam, no 3D scroll with “A-Left”,
  • could copy/paste this content into the Forum Reply box (after I discovered the Ctrl+e format for the comment)


There’s your problem. You didn’t comment out the entirety of the mousebind tag.

Let me add a little context. Try something like:

  <mousebind button="A-Left" action="Click">
    <action name="Unshade" />
  <mousebind button="A-Left" action="Drag">
    <action name="Move" />

  <mousebind button="A-Right" action="Press">

To see what you did wrong, here’s more or less what you did. Note the closing mousebind tag that has no opening.

  <mousebind button="A-Left" action="Click">
    <action name="Unshade" />
  <!-- <mousebind button="A-Left" action="Drag">
    <action name="Move" /> -->

  <mousebind button="A-Right" action="Press">

In essense you made this:

  <mousebind button="A-Left" action="Click">
    <action name="Unshade" />

  <mousebind button="A-Right" action="Press">

When you actually wanted to make this:

  <mousebind button="A-Left" action="Click">
    <action name="Unshade" />

  <mousebind button="A-Right" action="Press">

Put more generally, you want to comment out both the opening and closing tags.

1 Like

wxl, thank you.
I will study your examples carefully.
Now I see why a dedicated config editor could be a wise investment in time and effort.

On the CamBam forum, I have got the first hint that CamBam has problems with some key/mouse combinations.
Another avenue to chase down.

But, I will get on top of config editing.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.