Bug... Failed Snap Daemon in Lubuntu 22.04 LTS. No Firefox. Help please

Hello Lubuntu community,

I just tested a live boot of a burned DVD containing the latest Lubuntu 22.04 LTS.

  1. It was really slow to load. It took 20 minutes for the desktop to show up. On Lubuntu 20.04.3 LTS it only takes 5 minutes.

  2. During the loading of the live boot there was an error that said

“Failed Snap Daemon”

  1. In the live boot desktop, Firefox is missing! Please fix this.
1 Like

An ISO when written to DVD media is very slow; as that’s not the intended media for installation; these days the intended media is USB-thumb-drive, or loading the ISO direct off disk/ssd.

Yes it takes ages on DVD; the last ISO I burned to DVD media I think was in the groovy cycle (or hirsute) because of changes in the boot process & the thumb-drives weren’t booting at that time, I burnt it to DVD to see if it burnt there - results were identical to thumb-drive just far slower with the various dailies (just taking much longer).

All of Ubuntu ISOs & flavors of Ubuntu (such as Lubuntu) are created in the same manner, and it varies per release - intentionally so it’s the same process for all architectures (be it amd64, arm64, s390x, ppc64el, armh7 etc). Ubuntu 20.04 LTS media was the last before these changes were implemented (where amd64 was different to other architectures on focal and prior releases).

Ubuntu have no intention of changing this, or speeding up DVD media as it’s only a used by a handful of people. Note: I’m repeating here my understanding of what I’ve gleaned from discussions upstream over various issues, some of which I’ll alluded to; slowness was not ideal, but as it still worked to install it wasn’t a showstopper

Your issue may not be the DVD media itself, some boxes take >10 mins from thumb-drive due to issues related to firmware, this will likely add extra time if DVD media is used too, but that issue is not serious because the media still boots; and is only an issue with the ISO itself, so once the system is installed all is perfect.

No new media will be created until Lubuntu 22.04.1 LTS media is created in a few months; unless a series flaw is discovered which will force it. To get issues like what you describe fixed, they need to be discovered in alpha or beta stages & fixed before release & be deemed show stoppers; release has already occurred. The slow boot was seen as a documentation issue primarily as it affects systems only prior to installation (and an estimated fraction of 1% of users).

firefox was strongly tested; it had it’s on discord room during the beta cycle (as Lubuntu did too) and some issues were noted (and bugs filed), but all but a few have been resolved with the remaining ones being worked on by Mozilla. The snap daemon issue maybe related to media (were there any squashfs errors?, did media verification complete successfully? etc) or related to DVD media itself, but if it was DVD related, a bug report would need to be filed & issue is unlikely to be fixed prior to Lubuntu 20.04.1 LTS media, especially if the install itself works (ie. fix is likely to be deemed to be a documentation issue I suspect given it’s DVD installers only - but that’s my opinion only!)

Your testing is now too late, as we’ve released our Lubuntu 22.04 LTS product already, but thank you for testing, but try and perform the testing next time before release so we can act on it.

Please note: The opinions I’ve expressed here are my own. Much of the decisions as they relate to ISO media would be done by Ubuntu teams upstream with more understanding than my own. I’m largely a QA (Quality Assurance) tester in those processes.

4 Likes

What do you mean? That Firefox is not installed on the live system? Or that the icon on the desktop is missing or the starter in the panel?

Firefox is now a snap. And if snapd is not running, then also Firefox is not working.
I booted the 22.04 ISO in a virtual machine. It was fast, snapd was running and Firefox started without any problems.

2 Likes

After everything finished loading into the Live boot and you have the desktop with the wallpaper of that jellyfish, there is no Firefox icon on the taskbar.

I looked in the Linux style “start menu” and Firefox is not in the internet section. I even searched for it in the search box.

Before I burned my Lubuntu ISO to a blank DVD-R, I verified the SHA256 sum online. I even verified that Nero 8 Micro was successful in writing the files to the DVD using the verify checkbox option.

1 Like

The “Failed Snap Daemon” error was the only error message that showed up.

I am no expert in Linux, but I hope I’ve given enough information.

That sounds like you did everything right (I’ve not used nero in over a decade so I have to assume it’s still okay)

You’ll need to file a bug report for us to explore further, to do this you should

  • boot your Lubuntu 22.04 ISO on your hardware where this is occurring, retry to create the issue and if it happens, then do the following

  • open a terminal (Ctrl+Alt+Tor via menu) and type

ubuntu-bug snapd

Follow the prompts (logging into launchpad if you’re not logged in) as this will provide us & upstream Ubuntu with more details that we can check out. It might require us to write the ISO to DVD media & confirm, if it’s a timing issue (my suspicion but only one possible cause) it’d need to be explore, but the answer maybe we had a note on the next release media (22.04.1) that firefox will not run in live sessions when booted from DVD media, but then again they may decide something different (increasing wait time or other), but it could show something else to where my mind has gone as to possible causes - we’ll have to wait and see.

Please post the bug report URL here (I’ll likely see it when posted, but they can be missed)

Some links on filing bugs are

ps: I actually wrote this message last night (my local time), but I was hoping for an answer on what package to file bug report against as we cannot use firefox… I didn’t get a response to my query, so I’ve used snapd… Note: the package maybe changed after filing if I’ve given a wrong package

2 Likes

I’m not very good at using Linux. Terminal commands often blow up on me. I can post a Youtube video of the machine booting up if that’s easier.

1 Like

Sorry, No it isn’t…

We want details from your logs, so unless you’re going to page through system logs slowly (which would take hours of filming) we don’t have sufficient detail to confirm what you’ve already provided.

The alternative is for someone else to re-create the issue, then they file the bug report so we can explore their filed report.

Details are needed of your hardware, firmware, components, & boot messages etc… details of your installation media & internal validation on running system where issue occurs… all of which are obtained via the ubuntu-bug command to file a bug report, OR if the bug is filed on a browser using this link THEN later the command apport-collect (with bug ID from the prior bug created) from terminal when it’s in the position which I described in my prior comment.

The ubuntu-bug does everything, where as the apport-collect is used to get the required details from a browser reported bug report; but it’s the same process. I think the single step ubuntu-bug is easier.

1 Like

I understand. You need a detailed bug report as to why the “Failed Snap Daemon” shows up on the screen. I was assuming a video of the error showing up on my PC screen would be good enough.

I don’t like how complicated it is to do things in Linux. That bug reporting system looks too complicated to me to use regarding my level of software skills. Maybe I will try it out or not. Sorry.

2 Likes

Yeah, sorry I’ve reconsidered the steps…

You normally would enter ubuntu-bug snapd in a terminal; which will start some processes off, that will gather detail then request permission to open the browser so you can login & the gathered details can then be uploaded. The largest hassle here to me, is the creation of an account on launchpad.

The browser however is firefox , which isn’t running for you… so you’ll be forced to use the file-online (that can be done on another box which is it’s major benefit) then run the apport-collect on your actual box… That would still require you to give permission so upload can occur; which is done via firefox so a problem here too.

Whilst I don’t consider the command ubuntu-bug or apport-collect difficult, you’ll have issues currently given your issue is with firefox, and that won’t be very user-friendly (the tools jumping to firefox was intended to make it easier for end-users, but given that’s the current issue - its making it harder here!)…

If I get the chance, I’ll write Lubuntu 22.04 LTS to a DVD & give it a try; then maybe I can be the “someone else” in my prior message.

Thanks for your issue report, and replies to my questions.

1 Like

I wrote the Lubuntu 22.04 LTS image to a DVDR. Booted it up on

hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

and beyond taking ages to boot (which I’d remembered) it being noisy (this box is usually only tested with thumb-drives), it eventually booted. On opening firefox there is the delay which occurs now on first run due to snap package (the snap image on media is squashfs which needs to be unompressed*) then I get the firefox window and a “Welcome to Firefox”.

To look at what your actual issue, at least to me, a bug report is needed so we have more specific details we can examine. Presently from my just-run test, the likely issue to me is back to media write (mostly as I use thumb-drives which aren’t the most reliable media being made to cost & failures occur)

  1. Yes it’s slow to load; I didn’t time it; but that is expected as it’s assumed these days thumb-drive media is used; and the only checks performed for those still using DVDs is that it boots, runs and can install - even if slow.

  2. I could not replicate that issue

  3. firefox is present when ISO is written to thumb-drive, or DVDR and booted.

1 Like

I did get a reply to this… It was after midnight my local time and I just turned the box off without noticing it’d come…

<ogra> the apport fix is already pending to point you to the same url as "snap info firefox" when calling ubuntu-bug 
<ogra> also try starting it from a terminal, that might give some hints about potential issues

The last line contains the best clue; try running firefox from terminal and it may provide clues that allow us to help you. It may also provide details you can post into this discourse so we can help you too.

Sorry, I should have thought of that earlier; alas didn’t :frowning:

1 Like

If you have an active internet connection and snapd failed, you could share the output of the snapd status:

systemctl status snapd | pastebinit -b dpaste.com

This command prints an URL which you should share here.

1 Like

It was suggested to post this by KGIII.

Download a new iso from the official Lubuntu website.
Created a bootable DVD using Xfburn.
Booted from splash screen using safe graphics mode.

The errors.
Failed to start Thermal Daemon Service.
Failed to Start Modem Manager.
Failed to Start Disk Manager.
Failed to Start Snap Daemon.

That’s it screen goes blank I had to hard power off with the power button on the front panel of the desktop.

3 Likes

This looks like confirmation of this issue - Serious bug... Failed Snap Daemon in Lubuntu 22.04 LTS. No Firefox. Help please

Thank you for reporting; I’ll test some more with the DVD I created.

(The new post has been added to the existing thread)

Thanks for the hard work. Sorry I couldn’t be much help.

FWIW, I quit using USB thumb drives for making Linux boot drives years ago. More on this below:

I’ve been trying out Linux for about 8 years. The distros I tried would sometimes bug up or I run out of memory in the Live boot space. This would cause the USB to never stop blinking it’s activity LED. I had no choice but to press the reset button on the PC or turn the PC off by holding down the power button. I was afraid I would damage my USB by doing this. (Just like how you would yank out a USB drive while it’s still transferring files) So to prevent the possibility of damage to my hardware, I switched to using only burnt DVDs.

BTW, I forgot to mention, I used safe graphics mode too when I booted the new Lubuntu DVD.

I still use a CRT monitor and a number of Linux distros don’t like it, so I turn on safe graphics mode on the distros I test. However, I am impressed that the latest Linux releases I tried yesterday are actually making it to the Live boot desktop! I tried the newest PCLinuxOS, Xubuntu as well as Lubuntu. All three successfully made it.

That’s quite surprising seeing out of the selection of old Ubuntu 20.04 LTS based distros, and Arch and Debian distros I tried last year, Only Lubuntu 20.04 made it to the Live boot desktop. Thank you Linux community for improving hardware support!

P.S. I am using Firefox on the new PCLinuxOS to type this. It’s working well, but… when I tested the new Xubuntu, it’s web browser is broken, but there is no error message beforehand. It only gives me an error message when I click the icon and it won’t launch the browser. Maybe it’s related to the snap daemon failure on Lubuntu…

1 Like

Update.

Success.

2 previous iso downloads and 2 failed attempts using usb flash drive bootable media.

3rd iso download and 1 failed attempt using DVD bootable media.

4th iso download and successful install using usb flash drive bootable media.

Perhaps maybe bad iso downloads.
No way to really know I guess.

2 Likes

I’ve booted the DVDR I created in post 11 of this thread on the same old box, but this time using safe graphics mode

hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

and firefox is running for me (both when started via qterminal or menu)

I actually booted the box twice with one session getting a black screen. On the black screen boot I just switched to text terminal, killed Xorg & the machine sent me back to sddm or the greeter, I logged in as “lubuntu” and it worked fine from then on. I checked for squashfs (media errors) and there were none (alas I do see errors on access cdrom/sr0), but this old video card has known issues with nouveau on recent kernels (esp. with GNOME, KDE, recently MATE…), so I’d need to check for issues on other boxes/video cards before I was willing to treat it as a bug (and need a run without I/O errors on dev sr0)

1 Like

@computerdude92 Are you sure that your ISO is good? This sounds like something a damaged download could easily cause.

To check your ISO from Linux using a SHA256 checksum:

  1. Open the folder that your Lubuntu 22.04 image is located in.
  2. Open a terminal window within this folder. You can usually do this by right-clicking in a blank area of the folder, and clicking “Open Terminal” or something. The option might also be hiding underneath a “Tools” menu or something along those lines.
  3. Once the terminal is open, type this command:
sha256sum ./lubuntu-22.04-desktop-amd64.iso
  1. This command will generate a very long string that ought to look exactly like this:
15e7c0b5e0bd1fe3436e7a83d25a26f828694f5a1a6ce81bc4be955ae39ba128
  1. Carefully compare the string generated by the above command with the string posted here. If so much as one character is off, your ISO is damaged. If this is the case, delete the ISO, download it again, and check it using this procedure. Once you have a good ISO, you can burn a new DVD and try again.

Also make sure to use a “Verify written data” feature (or whatever equivalent your DVD burning software provides) to ensure that the data on your DVD isn’t corrupted - a wonky DVD will cause just as bad of problems as a bad ISO download (maybe even worse). It also may be a good idea to close all open programs before writing the DVD, and maybe even set the writing speed to 1x - this will make the writing process take time and eternity, but it will also make the process more reliable.

If even a good DVD with a good ISO isn’t working, you may want to try using a USB drive. It might be possible that your hardware’s DVD drive has some incompatibility that’s making things go haywire, and using a USB drive may make things work. I seriously doubt this is the problem, but I’ve had weirder things happen, so it’s worth a shot if all else fails.

4 Likes