Brother HL-2240D stopped printing probably due to some updates

$ lsb_release -a
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 039: ID 04f9:0040 Brother Industries, Ltd HL-2240D series
… and more unrelated

I hope this suffices for now. I am not very familiar with cups or how it works, if any more logs etc. are required, please tell me. As visible above, the printer is connected via USB.

The point is that the printer worked fine for a long time, also in Lubuntu 20.04. Some days ago - I do not know exactly why and when - it ceased printing. It is still visible, it does not show any error messages, toner is OK, test page can be printed from the printer (switch on printer with “Go” button pressed), but no action can be initiated from the PC. The queue is visible, print jobs can be created, show as processing, and deleted at will, just as it should be, but none of them - including test or self test pages - seem to activate the printer. It remains silent.

It has taken me some time to verify that the printer itself seems to be OK, that the USB connection seems to be OK (it is reckognized every time). I have deleted and reinstalled in two ways, from the Brother site and as a generic printer that was recognized correctly. I have searched for solutions in the net, including this site and others (whatever pops up from search), but none of the solutions have worked. Furthermore, most of them describe somewhat diffferent problems, and many assume that new installation does not work, which has worked for me.

So perhaps there is a solution to all of this, and perhaps someone could enlighten me. I would be grateful. Thanks in advance!

Problem solved in a simple way. I have ignored for too long the system messages that I should reboot after updates, because I had several VMs running at that time. After shutdown of all of them and a reboot of the host, printing works again. So - learned something, and if it ever happens to somebody else, this very short thread might be useful.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.