Broadcom Wifi Dell Inspiron / Latitude Lubuntu 20.04

Hi has anyone got experience with getting wifi running on this type of setup with recent versions of Lubuntu please?

I’ve been installing on a range of laptops and seem to be unable to get wifi working with Dell Inspiron and Latitude. I’ve used the additional drivers on a Macbook and on one Inspiron successfully, but now I think I need a bit of technical support with these as this step hasn’t worked on two of the laptops.

Latitude D530 - Hasn’t Worked
Latitude D430 - Working with Broadcom Driver

Inspiron 1501 - Hasn’t Worked

I’ve been using my wired connection in setup, but they need to be running wireless when in proper use.

The info I have got from the following:

lspci -vvnn | grep -A 9 Network

(Found on ask ubunutu)

Broadcom. BCM4311 DELL 1490

Status: Cap+ 66mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- SERR- <PERR- INTx-

Thanks

The one I have working is BCM4321 Dell Wireless 1500. Also says Kernel driver in use wl.

The ones not working don’t have that line about kernel driver in use.

One solution for problems with Broadcom drivers is to use a wired connection and then
enter Software Sources - go to the “Additional drivers” tab and you should then be able to download the proprietary drivers if they are listed there.

1 Like

Thanks for responding, yeah I tried that first, unfortunately whilst both laptops cards appear to be compatible with the broadcom proprietary driver, it hasn’t managed to breathe life into them yet.

1 Like

Have you tried going to the Broadcom support site?

On second thought - sorry I do not think this will help.

Can you provide the output text for the following commands:

lsmod

dmesg | grep wl

rfkill list all

For the Inspiron 1501

lsmod = Ubuntu Pastebin

dmesg | grep wl = Ubuntu Pastebin

rfkill list all = blank

Does wl stand for wireless lan ?

Also one little thing might be related or not. The restart button in Additional Drivers doesn’t seem to work whenever changes have been made.

So on the Inspiron 1501 I just tried the instructions from the answer to similar question : broadcom - Wireless not working with BCM4311 - not attached to wlan0 - Ask Ubuntu

I installed firmware-43-installer , which also required b43-fwcutter using Muon and then restarted the device. Low and behold my wireless networks have appeared. Next to try on the Latitude I think.

2 Likes

Good news - let us know the end results!

1 Like

Both working, I had to use the wifi on switch on the Latitude before it kicked in, it’s Fn + F2 on both of them.

So it’s definitely a case of using the firmware-43-installer for these.

I seem to remember having to toggle on/off with the D430 too, but that one has a physical switch next to the power button.

I think there’s some more Dells to test, so will pick them up probably tomorrow and see what new learning opportunities this week brings :wink:

2 Likes

Awesome! Thank you for sharing your solution! We all have good amounts of knowledge to share. :wink:

2 Likes

Ha ha. One day I may also understand what it is that I am doing, hopefully at least as I’d like to eventually be able to get my hands dirty in the source.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.