BCM4352 802.11ac wireless adapter not working properly lubuntu

I am not able to scan for wifi networks. I had the same adapter driver installed in hp-probook but it’s not working in hp-elitebook.

1 Like

Do you have another way to get online? Maybe the ability to tether your phone to your system, or use an Ethernet cable? If so, connect to the Internet that way. Update your system by pressing Ctrl+Alt+T to open a terminal, then run sudo apt update && sudo apt full-upgrade. Once that’s done, reboot, then open the Application Menu. Search for “Software Sources”, click it, and then select the “Additional Drivers” tab. You should be able to install the driver for your WiFi card from there.

Yes, I am currently using USB tethering. I did what you said and here’s the attachment.

I’m still not able to scan for wireless networks. I will the attachment that might be useful. screen capture 3 - YouTube

1 Like

Hey, looking at your screenshot, I had an idea. Were you able to connect to WiFi while booted from the live ISO? If so, try running sudo apt update && sudo apt full-upgrade from within the fully installed system while tethered to your phone and see if that fixes the problem. I had a laptop that behaved this way and updating Lubuntu fixed it. (Note that this command will use quite a bit of your mobile data, so be wary if you have data caps or tethering caps.)

edit: I just realized I had already said to do this earlier - if you already did it, sorry for the repetition, and let me know so we can try to figure out what’s going wrong.)

1 Like

yeah I already tried

sudo apt update && sudo apt full-upgrade

and it’s not working

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.