ALSA only w/ LXQt widget

I like that ALSA option, as I mainly run Kodi with only ALSA (no pulseaudio) and have LXQT as extra desktop. I wonder if it is possible to edit widget files to get drop down menu for ALSA, as I have two sound cards (hdmi and a dac). It only pics one now, the; hw:0

Greatful for help!

Back in the day when Lubuntu used LXDE, the default application for dealing with such things was alsamixer, a command line tool, albeit a graphical one. That will certainly work but it’s not going to integrate well into LXQt. Well, it can, but it’s tricky:

  1. make a script in your path that runs qterminal -e alsamixer
  2. replace pulseaudio-qt (under “external mixer” in the widget settings) with the name of that script— it seems you can’t use spaces in that field so you can’t call it directly.

Of course, that’s kind of funky, too. If you want a GUI, try the alsamixergui package.

If you use ALSA and PulseAudio alternately, consider adding a second widget that manages PulseAudio.


I had tried alsamixergui and even kmix, but it does not make me able to flip the cards for the widgets volume control, it is just control the one main card.

Yeah well, we’ve been using PulseAudio so long I’m not even sure what a good solution might be. But you can do what I said to use alsamixer.

I just wondered if you could easy edit the files for the widgets config and get a drop down menu with two cards (I can manage to find the right ones), as it looks like there is a drop down menu.

I think you’re missing what the widget does: it provides access to the external mixer. In other words, it doesn’t manage it. So while you could do whatever you want, the intention for the widget as developed is simply to provide access to an external tool.

Ok, my be get ridth of that drop down menu, as it looks like it does not do any thing than spell out one card.

The drop down definitely shows more than one card when they’re there:


Your mileage may vary when it comes to ALSA. Running ALSA only is simply not something that we really claim to support.

No, they do not do on my system, with only ALSA (I do not use pulseaudio). alsamixergui can not even show more than the default card either. alsamixer (bash) show both cards and so do kmixer.
Might be some other bad configuration from me.

This is my

#Alsa config (manualy added)
options snd_hda_intel index=0,3
options snd-usb-audio index=1,0

… and this is in
pcm.snd_hda_intel { type hw card 0 device 3 }

ctl.snd_hda_intel { type hw card 0 device 3 }

pcm.snd-usb-audio { type hw card 1 device 0 }
ctl.snd-usb-audio { type hw card 1 device 0 }

Grateful for help!

Does alsamixer (the terminal application) show both cards? If not, there’s something wrong with your ALSA setup.

However, because (like I said) we don’t claim to support ALSA-only setups, I can’t really provide much more help beyond that.

Yes, alsamixer show both cards.

I don’t see issues about this in lxqt-panel upstream, so I’m inclined to think it’s either been an issue no one’s ever faced or it’s already been fixed. If you’re not already, I’d try either 22.04 with the Lubuntu Backports PPA enabled or 23.10. At least that way you’re getting the latest software.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.