Admin right: real vnc

I’m new in Linux. I tried to install real vnc on lubuntu 23.04. I installed the generic script x64. The installation was ok. I started rvnc and logged in (at real vnc) - all ok. At the last step I got the error:

It seams I have not enought rights to do this step. I need admin rights. But I have the admin rights in lubuntu…

Question: is this a lububtu or real-vnc problem?

Thank you for answers


I can only give you a general tip for now. You are new to LInux, I am new to Real VNC :stuck_out_tongue:

If your system has enough memory (say more than 8 GB, or at least 8 GB) you could install e.g. Oracle’s VirtualBox (free software, GPLv3). You can use this to run another Lubuntu (or other OS’es as well) as guest operating system within your main system. In fact as a virtual machine. This allows you to install and test new software packages on the guest, without the risk of destroying anything while making changes to the host. So you can play with Real VNC.

Hope this helps. There are other solutions for running a virtual machine, but I personally like VirtualBox a lot. I have never had any problems with it.

However, my question is? Why would you run a VNC server on a Linux desktop machine?

(Real) VNC sounds like a great tool (with limitations, as I understand it) for managing Windows machines, dude. Linux is not Windows, so why bother managing Windows machines from Linux überhaupt?

What am I missing here??


Hi Fritz
Thank you for your reply. It helps not really. I have the following situation: I have a mini-pc (no display) for my astro gear. This pc is remote controlled. I use vnc for this remote control. In the past I had a Raspberry pi 4. These Raspi had real-vnc installed and it worked flawless. I tried different solutions (with other hw): microsoft remote desktop, team viewer usw. But all these solutions had more time delay compared with (real) vnc.
It can’t be a problem of real-vnc: it works with Ubuntu, Linux Mint, Win11… but not with Lubuntu. It must be a admin right problem in lubuntu.


I understand your use case now. Interesting. Seems you are an advanced Linux user already :stuck_out_tongue:

Still, trying it all out with VirtualBox (in a fresh OS) remains a very viable option. Especially when you have experimented already running commands as root (through sudo). Unexpected things may happen when you, more or less unwittingly, accidentally started an application as root (through sudo in a shell).

I don’t know how Real VNC organises its configuration, but you should check rights on any directory and file created by that application in e.g. ~/.config (“ls -l”). Strange things may happen if you have started an X11 application as root in a non-root graphical environment (‘the normal situation’). You could also lock out the normal user of logging in on a graphical session.

That’s why I suggested using VB. I will have a quick try myself later (in VB - since I am running Debian with LXQt at this phase in my life).

Besides that, I am very glad that you appreciate Lubuntu as you do (you have seen other distros already) and persist in getting VNC up and running :+1: :+1:

Apropo… I forgot to ask, is your astro gear box a Windows machine? If not, I’ve been using xrdp as server software (on LInux) in combination with freerdp2-x11 as client software (on Linux as well) with a very satisfying experience. I almost forgot about it, since I usually do not need to have access to a remote graphical desktop. So, I hardly use it; all I need to do on my remote machines can be done from the teminal. Some aspects of some popular desktop applications are not fully isolated. If Firefox is already running on the main (h/w) desktop, it will not start in an extra session from a remote desktop. Mitigated (killed on the server) with, in this example, from a terminal on the remote side: $ pkill -f firef.

I’ve installed the viewer in a Lubuntu VM. I’ve downloaded a deb file from the website, installed it as root with dpkg, and started the application as the normal user. Everything seems to be OK. I could not test it further, since I do not have a proper address of a remote machine.

I do not like RealVNC. Not at all. Maybe the viewer is opensource in some way, but they require you to register, which I did, but which I do not like.

The application looks ugly. Much like a very early X11 application, with bad font rendering. It looks very dated. “Very ugly, very ugly, indeed.”

The look an feel of the real-vnc window is (for me) not so important. In the daily use you don’t see it. Installing real-vnc viewer is not a problem in lubuntu - I have the problem with the server.
The mini-pc is a Mele quiter 3c. Win11 is pre-installed. I have two possibilities:

  • NINA on Win11 with ascom
  • KStars/Ekos on Linux (the Raspi has this solution) with indi

Both solutions can control my astro gear

While the mini-pc is booting up, the os has to check: is the home-wlan aviable?
if yes: log in and the control-pc can do the remote-connection
if no: go in hotspot-mode an the control pc has to login to the hotspot

At Win11 it’s not so easy to handle the hotspot decision. For Linux is this point not a problem. The second reason: Win11 is not a light system for the celeron-cpu.


I’ll check the point with thedirectory

What I understand now is that your mini-PC (a nice piece of hardware, I guess) is not always able to connect to your WiFi. Which seems fair enough. But I don’t understand what you mean with Hotspot in your setting.

If you have Linux software that can control your gear as well as Windows software, I would just advise you to not use Windows. The earlier remote/client software I use on Linux works fine on WiFi. Mostly no lag.

When I’m at home, the mini-pc should connect to the home-wifi. That is for both os (W11 and Linux) no problem.
When I’m not at home, the mini-pc has to go in the hotspot-mode. So I can connect the control-pc to this hot-spot. Linux: no problem, W11…not so easy

I kan’t find the problem.
Test in xubuntu: it works
Maybe I’ll change to xubuntu or linux mint

I have another suggestion that unlike Fritz’ original one is at least still in the same class of software. Use NoMachine. It’s by far the easiest and best solution I have found to remote access. I use it daily for work so this comes after not only using countless other solutions but really needing to have something to rely on.


Thanks for the info - I’ll try it.

Installation without problems - looks good. I think that’s a solution - tnx

1 Like

Woow. What a nice application, NoMachine NX. Beyond Teamviewer. Its performance is exceptionally well. At least at my WiFi network. In general scrolling in a browser works very neatly. My ultimate test is running Google Maps, and see what happens when you scroll a map around a bit. Never seen such a good performance on a local network. The NX compression algorithm of X11 data must be exceptionally well.

Thanks @wxl for providing this solution.

The advantage of the solution I suggested (running xrdp as server software on the remote end, and xfreerdp (package freerdp2-x11) as your local client) is that it provides a new separate X11 session. So, what you do remotely, should, in theory not interfere with what is going on at the actual machines display.

Unfortunately, not all applications (like important ones as Firefox) are designed to run in splendid isolation, or do they?. They work only in one X11 session, that is, only once for an user account. Quite understandable since they maintain all kind of their local state data in files and databases. Things would get over complicated if they should need to cater for multi session behaviour (e.g. merging browser history and bookmarks from multiple sessions in near real time).

In my ecosystem however it is perfectly normal to have more than one X11 session running for the same user on the same machine at the same time. It has its advantages, and I can live with the above described single user at a time-issue.

1 Like

Ok, for me is the problem solved. Thanks for all infos!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.