24.04 - Discover app store won't open

When I try to open ‘Discover’ app store from the menu nothing happens.

Tried opening from Terminal and got:
plasma-discover
org.kde.plasma.libdiscover: Couldn’t find the backend: “kns-backend” among (“kns-backend”, “packagekit-backend”, “snap-backend”, “fwupd-backend”)
fetch ratings! true
adding empty sources model QStandardItemModel(0x565f8bdfe630)

Tried:
plasma-discover --listbackends
Available backends:

  • kns-backend
  • packagekit-backend
  • snap-backend
  • fwupd-backend

All help is appreciated.

I have no problem loading it from the menu and no problem loading it from terminal. In terminal, it does indeed complain about the kns-backend, but this is a red herring as it still works.

Are you sure your installation was made with valid installation media? Like did you check the integrity as the manual states?

I did sha256sum the .iso file and used the ‘Startup Disk Creator’ to flash a usb drive, I used this same drive on my other computer and Discover works fine on it.
Is it possible to purge/re-install plasma-discover?

1 Like

Very strange. You can reinstall with sudo apt install —reinstall plasma-discover .

1 Like

It is very strange, I tried reinstall and it doesn’t help, guess I’ll just use apt to install things, thanks for your help.

One other thing you might try: sudo dpkg-reconfigure plasma-discover .

1 Like

If it works on another computer, it’s probably a hardware issue. Have you tried booting with safe graphics ?

1 Like

7 posts were split to a new topic: Failed to open \EFI\ubuntu\ - Not Found with Windows dual boot