22.04 wifi hotspot unable to connect - wrong password

Greetings!

Today I’ve installed the latest 22.04 on a mini pc that I would like to use the internal wifi adapter as a hotspot (so I could use it headless and access it through my iPad).

I can see that the WiFi adapter is visible, I can see other networks. I am creating a WiFi hotspot, already tried with or without password, is active, but I can’t connect (not connecting or wrong password error).

I’ve tried to opt-in the “additional drivers” of Realtek8821ce but the option is greyed out.

This is just drives me crazy…any tip would be much appreciated!

PS. I do know that this scenario is possible and the wifi adapter is working, cause I am already using it on a second disk with Mate distro.

Ubuntu Mate uses a different desktop and likely has a different default setup than Lubuntu.

What steps did you take to make your Lubuntu mini PC a hot spot? Is there something in the settings you tried? What options did you tick?

If your Ubuntu-MATE is 22.04 then I’d expect the same in Lubuntu, as both are built on the same Ubuntu base product with only the different GUI & gui-apps really differentiating them (ie. user interface & applications).

If Ubuntu-MATE works; then I’d explore that and look at what’s in it’s stack, and how that differs. If it’s an older release; it’s likely kernel related but again the differences between them are where I’d look, expecting when I found them I had the answer to making it work on the Lubuntu 22.04 LTS system.

(I QA-test Ubuntu-MATE on occasion, and I find no differences between them beyond UI & apps; if one does Lubuntu/Ubuntu-MATE does something, the other will in the same way)

1 Like

I’ve hit that “grayed-out” driver thing before. If it tells you the package name (which I think it does), just sudo apt install <package_name> in a terminal (replacing <package_name> with the driver package name), and see if that does the trick.

1 Like

I haven’t done anything special, just new Wi-Fi connection set as hotspot through settings.

My Ubuntu Mate is 20.04. As far as I can see thought Google, there are multiple reports for multiple distros at 22.04 with the same issue,

1 Like

If you’re trying to make a wireless hotspot out of your device, which is reads like you’re are trying that, you have to make sure your wireless device supports that.

If that’s what you’re trying to do, be sure to read the caveats here:

(Scroll down.)

3 Likes