22.04 my wifi is often disconnecting

Hello everyone !

I’ve been using Lubuntu for many years now (18.04) and it is the first time I am facing this weird issue : the wifi is disconnecting from times to times. On 21.10, everything was fine.

lspci tells me my Qualcomm Atheros AR9485 card is using the driver ath9k.

As wifi drivers is compiled from the kernel, I’ve reinstalled the latest one (sudo apt-get install --reinstall linux-image-$(uname -r)) with no success.

Do you have any idea ? Am I the only one facing this issue ?

Cheers

1 Like

Try to see if your driver works in a 22.04 live session. If it does not, then the new kernel must be the problem.

1 Like

Is it blocked ? Run the command below to see.

rfkill list

Oh from time to time you might want to check your router and turn off wifi legacy (a/b) as your device can use wifi n/g.

Thank for your replies :slight_smile:

I’ve browsed the internet on the live session with the same result : from times to times I have to reconnect to the router to still be connected. @BasilCat you think I should install the previous kernel ?

Here is the result of the rfkill list command :

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

From my understanding the problem is from my laptop (3 days ago with Lubuntu 21.10 everything was fine), not my router.

1 Like

Maybe press shift when you power on your computer, select advanced options for ubuntu, then select the 5.13 kernel. Maybe your WIFI will work then

1 Like

I’ll try that tonight ! Thank you for the advice :slight_smile:

If shift doesn’t work, press esc.

It’s not the router that is different but Linux driver. Some wireless Linux drivers have stability issues when connecting to routers with very old wifi a/b enabled.

1 Like

So far the 5.13 kernel seems to work perfectly. Thanks @BasilCat :slight_smile:

I’ll try tonight @thetick 's idea.

1 Like

After a quick search, my router is already not running a nor b wifi. It just can’t. So it’s not gonna help me.

So I have to check all the future kernel one per one and if it’s stable enough, I have to go back and use the 5.13 ?

Alternatively, you can try uninstalling the newer kernels that are buggy and simply keep the working ones.

If you find guides for Ubuntu, they’ll apply to Lubuntu as well since Lubuntu is mostly just Ubuntu with a different skin.

1 Like

Same issue. Upgraded to 22.04 and have constant problems with wifi. Its just keeps disconnecting.

Just a guess but maybe disable virtualization for the wifi device.

Reference: – [SOLVED] (was Intel VT/iommu error) Debian + Asus N550JV + Atheros AR9485 = painfully slow wifi - Debian User Forums

In the BIOS, disable the VT-d entry

OR

Disable the Intel IOMMU driver in the kernel boot parameters:

  • open /etc/default/grub
  • find the GRUB_CMDLINE_LINUX_DEFAULT option and append intel_iommu=off at the end of the parameters list
    example :
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet intel_iommu=off”
  • sudo update-grub

Finally you can try to disable power management and hardware encryption see same link above for details.