22.04 Lubuntu on 10 year old hardware (stay on topic please)

I have 22.04 Lubuntu installed on an old 2011 laptop with only 3GB of memory. It has dual core AMD Bobcat 1 GHz C50 processor with Radeon 6250 iGPU. It works great. With some Chrome tweaking it works well playing 1080p you tube videos with hardware acceleration. Just amazing!

Below are the performance tweaks I did for acceptable performance:

  1. Removed all snap apps, disabled snapd and apt holding snapd and firefox
  2. Enable 40% zswap (can switch to zstd with 5.16+ kernels)
  3. Change to a reasonable swappiness of 10
  4. Disable the mlocate indexing
  5. Disable wifi power management as battery is dead anyway
  6. Blacklist bluetooth drivers as I don’t need it and it actually slows Wifi on this laptop. I have since disabled bluetooth in the BIOS.
  7. Disabled qlipper as I only need one cut buffer. (suggested by kc2bez )
  8. Disabled print applet (suggested by kc2bez ) and disabled cups and related packages. I print docs from my wife’s Window’s laptop via home NAS.
  9. Disabled java for LibreOffice (makes huge performance improvement loading )
  10. Switched to performance governor for cpu and igpu as my battery is dead anyway

Most of the above changes I did are based on this website as I also run Linux Mint are some newer machines:

Are there any other suggestions for Lubuntu performance improvements for extremely slow processors with extremely low memory ?

Note please stay on topic as I previously posted most of the details above. It got moved to Off Topic ( my own fault for the original off topic replies).

5 Likes

What i’d do is:
Remove snapd.
Remove games and programs i don’t need or use.
Get UBlock origin to reduce cpu and ram load.
Disable bluetooth as it reduce battery.
(This can apply to any ubuntu flavor or install)

1 Like

I actually didn’t know I could disable Java for LibreOffice so thank you for that tip! :grinning:

Please explain in detail how you disabled java in Libreoffice.

I’ve tried to disable java in Libreoffice going into tools/options/advance and uncheck the java box and when I click apply the check mark returns.

Oh that is confusing!

If the window showing java path is completely empty (Lubuntu default) then java enable toggle is meaningless as there is no java program to start. This is why when you remove the check mark to enable java the removed check mark is not saved. LibreOffce should fix that confusion in their menu.

In my case I already had java installed with a path as I needed it for one of my custom applications. So removing the check mark disabled java for LibreOffice applications. LibreOffice Base which most users will not use is about the only LibreOffice feature requiring java enabled.

Please see my post above to Bartman.

If you have Lubuntu defaults, LibreOffice already has java inactive.

3 Likes

thetick

11h

Oh that is confusing!

If the window showing java path is completely empty (Lubuntu default) then java enable toggle is meaningless as there is no java program to start. This is why when you remove the check mark to enable java the removed check mark is not saved. LibreOffce should fix that confusion in their menu.

In my case I already had java installed with a path as I needed it for one of my custom applications. So removing the check mark disabled java for LibreOffice applications. LibreOffice Base which most users will not use is about the only LibreOffice feature requiring java enabled.
-------------------------------------------------------------------------------------------

I don’t want to enable java in Libreoffice and java is enabled by default in Libreoffice which is why the use java box is checked.

With a clean out of the box Lubutu 22.04 install java was not enabled for any of my machines.

Please check ‘ps -fe | grep java’ with LibreOffice apps running in background to know for sure. I believe java is only used for LibreBase.

<<removed some comments to stay on topic>>

2 Likes