22.04.1 won't boot on Gigabyte b560m ds3h ac i5-100400

My Dad got a prebuilt Gigabyte b560m ds3h ac i5-100400 desktop.
It has realtek wifi (RTL8821CE).
It was supposed to have Intel wifi but they subbed the motherboard and wifi card.
My Dad doesn’t care because it’ll run Windows.
I care because Linux is better.
Anyways I had a 20.4 lubuntu.
There were a few errors but it booted.

[ 1.954921] ACPI BIOS Error (bug): Could not resolve symbol [_SB.PC00.PGON.PBGE], AE_NOT_FOUND (20190816/psargs-330)
[ 1.954929] No Local Variables are initialized for Method [PGON]
[ 1.954930] Initialized Arguments for Method [PGON]: (1 arguments defined for method invocation)
[ 1.954930] Arg0: 000000002a6ff44e Integer 0000000000000000
[ 1.954934] ACPI Error: Aborting method _SB.PC00.PGON due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
[ 1.954939] ACPI Error: Aborting method _SB.PC00.PEG1.PG01._ON due to previous error (AE_NOT_FOUND) (20190816/psparse-529)

I wanted to try a later release so I downloaded lubuntu-22.04.1-desktop-amd64.iso.
It booted but after I selected lubuntu if gave errors and then seemed to freeze.

I waited a few minutes and nothing was happening so I pressed enter.
I then saw this:

I couldn’t do anything.
I then tried to boot the USB in my AMD computer and it worked fine.

You might want to check your question.

You mention 20.04.1 booted

then later mention 22.04.1 which failed to boot. Your title implies you’re asking about Lubuntu 20.04.1 which booted (but won’t boot).

Lubuntu 20.04.1 used the GA kernel stack; ie. 5.4 kernel, where as Lubuntu 22.04.1 uses the 5.15 kernel. The Lubuntu 20.04.5 media also uses that (5.15) kernel stack so I’d likely try 20.04.5 and see if that boots; as the would imply it’s a kernel related issue to me (if 20.04.5 fails to boot, but we’ll have more details (hopefully via proces of elimination) if it boots).

I do see many IO errors which reminds me of partition table problems in a screen you provided, but I’ve seen kernels that have problems with hardware give such errors before too; thus why I’d likely explore a different 20.04 kernel stack (using the jammy stack given it exists).

This is 20.04.5:


It shows this, then the graphic lubuntu screen, then back to this.
Enter does nothing, it seems frozen at this point.

I found this post with the same error:
https://forums.linuxmint.com/viewtopic.php?t=328045

I do have onboard video and pcie.
I’ll dig around in the BIOS.

EDIT: I changed the onboard video from auto to disabled and that didn’t help.
It’s not completely frozen, I pulled the flash drive out before I shut the computer off and I got squashfs IO errors.

EDIT2: What would be another good distro to try?

It is not nice to ask on a specific Lubuntu forum about other distros :stuck_out_tongue:

A few remarks for you:

  • squashfs errors are normal if you pull the stick that is running the OS. You should always try to /sbin/shutdown now before pulling the stick;

  • current Lubuntu 22.04.1 works fine with your wifi card (with the rtw88_8821ce driver out of the box from the kernel)

  • current SparkyLinux 6.4 / LXQt works with your wifi card. It is a nice distro, Look-and-feel is not as polished as Lubuntu, but it is nice enough. It does not use snap, which some say might be an advantage;

  • Debian 11.4 / LXQt has problems with your wifi card (its earlier kernel should support it, but there is a bug: wifi gets shut off due to a faulty implementation of standby). Debian also does not use snaps;

  • I hear great things about Garuda / LXQt-kwin. Not tested it personally sofar;
    UPDATE I have tested Garuda quickly in VirtualBox. It is an interesting distro. It implements a totally different GUI paradigma compared to standard LXQt. Interesting and ‘cute’. LXQt 1.1.0 and kernel 5.19 onboard. Very interesting!

  • try to install a fresh installation on an second USB stick, or a disposable external hard disk. It might help to see where your problem really is, without inherited dual boot or drive problems;

  • avoid to be smart with BIOS settings. In general the default settings are just fine (for typical mass marketed machines).

I tested a few other distros with LXQt, and at the end of the day, I really like Lubuntu’s implementation of LXQt. I am using Lubuntu right now for all my (two) desktops. Maybe I would prefer a Debian based system, but only because of some kind of unjustified fear of possible instability. Debian is renowned for its stability, but comes with the cost that its repositories and kernel are not cutting edge. Canonical provides us with a real nice base system. Lubuntu makes the user experience great :slight_smile:

Hi,

Your machine has a 10th gen Intel processor so you will need a very recent distro to support this recent hardware. Trying any distros from 2020 will likely result in many issues (ie the odd message referencing hsw/bdw (4th /5th gen Intel proc) from audio driver).

ACPI errors are from BIOS/UEFI walk through and may not be of any concern. APCI errors could also indicate a BIOS/UEFI, so make sure you have latest BIOS/UEFI installed.

The I/O errors imply your storage may be bad. Does this same machine work fine with Windows ?

How do I know which year they are from?

linuxmint-21-cinnamon-64bit.iso
lubuntu-20.04.5-desktop-amd64.iso
lubuntu-22.04.1-desktop-amd64.iso
manjaro-xfce-21.3.7-220816-linux515.iso

linuxmint (Linux version 5.15.0-41-generic) was the only one to boot fully to the desktop.
The resolution was not very good and it wouldn’t identify the display.
It wouldn’t shutdown though.

I really prefer lubuntu.
Is there a live iso for a lubuntu development version?

I have the dmesg for linuxmint which I uploaded to

http://iso.qa.ubuntu.com/qatracker/milestones/433/builds/257546/downloads

That’ll work as a live iso, running from USB just fine (assuming your hardware is compatible).

2 Likes

Thanks.
It seems to be a bit better but I still don’t get a graphical screen (the spinning powered by lubuntu screen shows).
I get the same ACPI BIOS errors but those shouldn’t stop it from working.
I can press alt-F3 (I think that was it) to get a console login screen but I don’t know the userid/password.

EDIT: I read this August 2021 article about Intel DG1 graphics drivers.
I think it says I’ll need kernel-5.15.

1 Like

If you note the daily in the link @KGIII provided, its dated 2022-August-29 as currently there are some build issues & new dailies haven’t been possible for the last few days. When the current issue is resolved, the ISO will contain the 5.19 kernel (instead of 5.15) which I’ll suggest is worth trying again.

Also if you don’t like dealing with the dates in the URL, my zsync script uses http://cdimage.ubuntu.com/lubuntu/daily-live/current/kinetic-desktop-amd64.iso (ie. current instead of date)

2 Likes

I tried the Sep 10 version, it still doesn’t boot.
It gets to “Terminate Plymouth Boot Screen.”, waits for what seems like minutes but probably isn’t, “snd_hda_intel 0000:04:00.0: HSW/BDW HD-audio HDMI/DP requires binding with gfx driver” so I think the Intel DG1 graphics are not in the kernel but I don’t know why it won’t boot to VGA.

EDIT: DG1 drivers apparently went in Kernel 5.11.

@bjlockie

You need enter the BIOS\UEFI settings and see if is possible change the ACPI version, start in BIOS mode and disabling any security settings.
Also try start the machine using USB Lubuntu live using alternate start options.

Try start the USB Lubuntu live using nomodeset kernel command

1 Like