Won't install on VIA Nano netbook

Hi! I tried installing Lubuntu 21.10 on Lenovo Ideapad S12 with VIA (Centaur) Nano U2250. An allegedly 64-bit CPU. And 2GB of RAM.
While I could install regular Ubuntu several years ago, I now took this with message Lubuntu.
Do Linux still support those CPUs? May be 64-bit is disabled? Any clue? Thank you!

When I look this up, there’s many reports for this that come up but only one answer seems to properly explain the problem.

This doesn’t seem entirely like the reason for your system since Lenovo doesn’t offer 64-bit anything for the VIA model in its own support page.

See the following for the last BIOS update they have for this model:

Lubuntu doesn’t have 32-bit images anymore so nothing can be done about getting Lubuntu on 32-bit systems.

I wanted to rule out the processor but when I look up the chip that comes on the model, I see that it is 64-bit.

Ubuntu has a community wiki page for installing Ubuntu on this system and its related family of products but it is stale and unmaintained (i.e. unsupported):

At this point, I can’t really confirm or deny whether or not Lubuntu will run on your machine since I’m getting conflicting results… what you can try is to see if Lubuntu 20.04.3 LTS will come up at all. You can grab the live image from downloads page:

If that still fails, then I’m not too sure what else can be done. It could be firmware, it could be that your system is actually 32-bit, it could be newer kernels not meshing right on your system… etc.


Thank you so much for the detailed reply. I’ve seen reproduced the error whenever I try any 64-bit distro. Even some based on previous Ubuntu 18.04 LTS or Fedora. Lubuntu 20.04 at least showed up first menu screen, then crashed when trying installing. 32-bit distros at least gets you to first GUI screens, then nothing: many times ends-up with “Unable to find a medium containing a live filesystem”. Interestingly, this machine had Ubuntu 14.04 installed and worked so yes, until some time in the past support was there.

The bit that grabs me is

“Unable to find a medium containing a live file system
Attempt interactive netbook from a URL?”

That means you either didn’t verify the ISO using Ubuntu instructions or as per Lubuntu manual instructions or the write of a valid ISO to your boot media was faulty. (thus the reporting that it was unable to find it & offer to go online & download valid ISO)

As to your hardware issues; sorry I can’t help there so I’ll refer you back to @That_Random_Guy’s response, but invalid installation media is what I see, so did you verify the media is valid using another device? If the media was validated on at least two other devices; then I’d return to blaming a specific hardware issue with your VIA Nano netbook.

1 Like

Thank you all. I was going to trow the towel when a last attempt somewhat succeed and I managed to install Lubuntu 18.04 (32-bit). While I see support ended in 2021, updater tells basic support is granted until 2023. Is that right?
Not ideal but at least I can do something!

Lubuntu 18.04 LTS is end-of-life with regards Lubuntu.

I’ll refer you to

I’ll suggest you run ubuntu-support-status and you can see which packages are common with Ubuntu 18.04 LTS (which uses the GNOME desktop & comes with 5 years of supported life; meaning it’s supported till 2023-April), and those which aren’t supported.

If you look in the second link you’ll see me make mention of ubuntu-support-status, using an old IBM Thinkpad t43 on which I still use Ubuntu 18.04 LTS (with LXDE) or what was Lubuntu 18.04 LTS (it’s i386 only so whilst it was capable of running 18.10 & 19.04; they are fully-EOL so it runs 18.04 with partial support). With that machine; my alternative is Debian (which I know it runs, I used it in QA-testing of Debian Buster & Bullseye) but given how I use that box I’ve not felt a need to switch.

FYI: I’ll now move this thread from Support to Off-topic as 18.04 is EOL & is not a Lubuntu Support issue.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.