When a convertible is standing like the letter A on the table, then the view is not turning around

In the operating system Windows, I know that the view is turning around, namely 180 degree.
Three questions:

  1. How can I make it that it is turning around 180 degree?
  2. Could it be that LXQt 0.17.0 (in Lubuntu 22.04) is too old, and that it is working in the latest version of LXQt?
  3. If it does not work in the latest version of LXQt, should I I report it on Issues · lxqt/lxqt · GitHub?

Thank you for an answer in advance.

Sorry, I’m not sure what you’re asking.

I get the feeling that its related to a device where you expect turning the device upside down, will cause the display itself to be redrawn upside down, which to me is more a function of software much lower in the stack (ie. closer to kernel than the GUI/desktop).

ie. I’d expect the same behavior in Xubuntu 22.04 LTS, Kubuntu 22.04 LTS & Ubuntu 22.04 LTS (ie. GNOME)? I’d not install, just test them live, and if there too as I believe, the issue relates to either the 5.15 kernel stack currently available to 22.04, or something else related to Ubuntu stack (esp. if it works as you wish on another non-Ubuntu system using 5.15 kernel).

But note I don’t really understand what you’re asking, thus could be far from your issue, plus I have (I think) one device that does what I’m trying to describe, but I avoid using it preferring my older desktops (with larger screens, real keyboards).

1 Like

They’re describing “tent mode”. Some laptops with touchscreens can be converted to tablets by folding the screen over so that the back of the screen lays on the bottom of the laptop, resulting in the screen and the keyboard being on opposite sides of the laptop chassis. (This Chromebook picture on Amazon sums it up fairly well.) These laptops can (at least usually AFAIK) be folded so that the screen’s back isn’t quite touching the bottom of the laptop, and the resulting configuration can be stood on a table such that it resembles a tent or the letter A. This results in the screen being upside-down, requiring it to be rotated 180 degrees for it to look normal. So you’re right about something needing to trigger the screen to rotate, probably as a result of a gravity sensor or the like.

Could you post the make and model of your laptop (something like “Dell Inspiron 7000” is what I’m talking about)? That may aid in fixing or at least diagnosing the problem.

Yes, that’s right. That is exactly what I mean.

The model of the convertible:
Medion Akoya E2293 (MD62347) (MSN 30032552)

You might try installing a mainline Linux kernel and see if that makes your system work right. I usually use the Mainline tool to do stuff like this, which you can install with these instructions: Mainline – Another Tool to Install Latest Kernel in Ubuntu / Linux Mint | UbuntuHandbook

@ArrayBolt3
I installed Ubuntu Mainline Kernel Installer.
Then I opened Ubuntu Mainline Kernel Installer. There I marked the latest kernel version, namely 5.19.0. Then I installed it. Then I restarted the computer. But during the boot there was this text on the screen:

error: bad shim signature.
error: you need to load the kernel first.

Same issue for 5.18.15.
So, because I could not run a new kernel version, I could not test the tent-mode.

Ah, sounds like Secure Boot is still on. Do you have any other operating systems on this computer?

On the used computer there is only Lubuntu 22.04. Should I try to disable Secure Boot in the BIOS?

Are you saying
Preferences > LXQt Settings > Monitor Settings > Advanced > Rotation > Inverted
…does not work ?

For auto-rotation, it’s tricky. (the touchpad or touchscreen needs to be rotated too).

@humpty
This worked for me:
Preferences > LXQt Settings > Monitor Settings > Advanced > Rotation > Inverted
The touch does not work correctly because it is inverted. But at least the view is turned to 180 degree, and mouse and keyboard are working correctly.

Thank you for your help.

Now to the auto-rotation:
I tried to follow the description of INSTALLER.txt but I failed at UDEV RULES when creating groups. I reported two bugs:

Maybe you have a solution for the last reported bug?
Thank you for an answer in advance.

1 Like

I have not tried it myself. But if it was me, I would not bother.
I would probably make do with two shortcut keys,

Preferences > LXQt Settings > Shortcut Keys > Add
Shift-F1
Command: xrandr -o normal
OK
Add
Shift-F2
Command: xrandr -o inverted
OK
Close

(i hope that’s self explanatory).

2 Likes

@humpty

So cool!!
Thank you for those shortcuts.

Do you have an idea how I could also change the touch to 180 degree, because at the moment it is just the view that is turning around?

I’ve not tried it but just looking at the link I gave, you might try

xsetwacom set touch rotate half
xsetwacom set touch rotate none

and put them with the other commands into scripts. Then call the scripts with the shortcut keys.

It did not work. I think that it does not work because I don’t use a Wacom. It is a medion convertible that I use. If I do in the terminal this (impluse: xsetwacom man page - xorg-x11-drv-wacom - General Commands)
xsetwacom list
then threre is nothing. So I think that xsetwacom can’t be the solution.

Do you have an other idea?

I don’t think it’s wacom compatible.

The touch’screen’ on the tablet I have does not work at all, so I can’t help much with that.

Some people have managed to rotate with libinput instead.
To get an idea if your touchscreen shows up for libinput, type

xinput list
On my device, I get a mouse and touch’pad’ but no touch’screen’.

This is the result of xinput list:

Thanks to Script to rotate the screen and touch devices on modern Linux desktops. Great for convertible laptops. · GitHub, I did this as command for a Shift+F3-shortcut to invert the touchpad:
xinput set-prop "Touchpad" "Coordinate Transformation Matrix" -1 0 1 0 -1 1 0 0 1

Bur it does not work.
Instead of “Touchpad” I tried also “pointer” and “HTIX5288:00 0911:5288 Touchpad”.
Bur it still does not work.

Any help?

1 Like

I know it works with ‘Mouse’.
Some people have had success with ‘Virtual core XTEST pointer’

(I wonder what is your id=9 ? 2808:5012 ?)
You can use the number instead of the text.

I tried also:

  • Mouse
  • HTIX5288:00 0911:5288 Mouse
  • Virtual core XTEST pointer
  • FTSC1000:00 2808:5012

Example for a command:
xinput set-prop ‘HTIX5288:00 0911:5288 Touchpad’ ‘Coordinate Transformation Matrix’ -1 0 1 0 -1 1 0 0 1

But it still doesn’t work.

Try using the number, and use double quotes;

xinput set-prop 11 "Coordinate Transformation Matrix" -1 0 1 0 -1 1 0 0 1

xinput set-prop 9 "Coordinate Transformation Matrix" -1 0 1 0 -1 1 0 0 1

Is it the touchpad you are trying to invert or the touchscreen ?