User Account Lost All Permissions - Can't install from Discover

Very new to Lubuntu and Linux in general, so will need walking through this please.

I installed Lubuntu on an old laptop to give it a new lease of life. Was working fine, but believe I may have messed up my user permissions. I added a user account and tried to mirror the permissions of the main user, but now I can’t install using Discover on either account. I have installed previously and the passwords are getting me logged in, so that must be correct.

The error message from Discover is: no authorization to execute this operation

I have seen a similar thread, but is closed and doesn’t appear to have a solution.

uname -a
Linux daisy-laptop 5.4.0-31-generic #35-Ubuntu SMP Thu May 7 20:20:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Tried to install any application to test:

qrc:/qml/Feedback.qml:2:1: module “org.kde.userfeedback” is not installed
adding empty sources model QStandardItemModel(0x55cea19638f0)
org.kde.plasma.libdiscover: Couldn’t find a category for “fwupd-backend”
took really long to fetch PackageKitBackend(0x55cea195bc70)
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
percentage cannot be calculated
PackageKit error: PackageKit::Transaction::ErrorNotAuthorized “You have no authorisation to execute this operation” “Failed to obtain authentication.”

It also appears that any modification I try to make to a user now fails, so I am really really stuck.
Can anyone help me get to grips with this please? Thanks


Yes, there’s a bug in *buntu that messes up the permissions when a user is created, there’s no solution so far and my guess is it will take a long time to fix this, it has been reported HERE.

For the time being, the only solution is to have only 1 user.

As far as I can tell, the bug is only in LXQt’s GUI program that allows you to control users. If you add a user and set all groups and permissions using a terminal, you can work around it.

1 Like

I’ve tried from the command line and the results are the same, I’ve mentioned that on my posts and if I’m not mistaken other people too.

1 Like

Ok, my mistake. I thought it was GUI only because the bug was filed for lxqt-admin-user, which is the GUI tool. I can’t try it right now because I’m not on my Lubuntu machine.

I too, like @Thomas-N was of the belief the issue only occurs when using GUI tools, specifically to redact/remove permissions on a clean 20.04 install (ie. not 19.10 upgraded to 20.04)

This issue on on my todo list, my first intention was first to compare permissions on a 19.10 upgraded multi-user system looking for differences with the same done on 20.04, but I don’t have a release-upgraded system.

If the bug report is missing details, they should be added to that report; the package changed (or added to) to reflect issue, but my testing only saw it relating to the LXQt GUI tools. FYI: My testing was quick/limited (akin to Xubuntu’s second user testing; change permissions, logout, login again then quick test etc).

I have reinstalled it clean again, the reason I need accounts is because I deal with confidential data at times through work. So want to reduce the likelihood of my daughter inadvertently triggering a gdpr issue. To be honest I had issues with adding users in Ubuntu 18.04 as well I think, masked by other things though. Thanks for the responses, none of it made any sense to me, sounds really impressive though :slight_smile:

1 Like

I just tested it and on my recent Lubuntu 20.04 install, adding users in a terminal works without issues. This could be a possible workaround until the bug with the graphical tool is fixed.

In a terminal window, you can use the command:

sudo adduser name

To add a new user.

1 Like

Have you tried installing software after adding a new user? the problem is not creating the users (you can without a problem by either using the GUI or the terminal) the problem is not able to install software after a new user is created from any account.

Yes, I’m sorry I didn’t include that in my post.

Because @acor specifically mentioned getting errors when trying to install software using Discover, I used Discover to install something - after adding a new user, doing some logging in and out of both accounts and rebooting to simulate what he had probably done - and it installed without errors. Uninstalling worked fine as well.

This seemed to indicate the bug only occurs when using the GUI. Or perhaps there is something else that happens on your install that doesn’t happen on mine. Have you done anything special with your system, or is it a very fresh install?

Another indication that the bug is related to this specific GUI tool is that, so far, it appears to only affect Lubuntu users. The terminal tools used are not specific to Lubuntu. That’s not to say it’s impossible, but then there should be some other factor making this happen specifically on Lubuntu 20.04.

If you add a new user using the terminal, without touching the GUI tool, do you get the exact same errors? Or is there a difference?

Fresh install (20.04) nothing added or modified, it seems this occurs only on fresh installs and not upgrades, the systems I’ve tried were all fresh installs, and this bug seems to affect only 20.04, I tried on a 19.10 and works like it should

Thanks I will try this. Will the new user also have admin privileges?

You can clone the rights of the “main” account if you like and the problem will happen, just adding a second user breaks the system.

Just to add. It was a fresh install of 20.04. I caused further problems when trying to mirror the user privileges / groups. Using the GUI as don’t have much experience with the terminal.

The new user by default will not have admin privileges. If you want to give the new user admin privileges, you have to add the user to the sudo group. You can do this in the terminal with:
sudo usermod -a -G sudo username

Similarly, you can add the user to any existing group with the command:
sudo usermod -a -G groupname username

You can read more information about this command by typing man usermod

To check which groups a user is a member of, you can use the command groups
(for more info, type man groups)

As you can see from this thread, experiences vary. On my fresh 20.04 install, I had no issues after adding a new user using the terminal, but @ErikTheRed did. Please report back if you experienced issues when doing it this way, as that could help resolve the bug that you previously encountered.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.