Unable to use PCMan since update

I have a fresh install of Lubuntu 20.04 on an Intel NUC hosting my Nextcloud server.
Ever since a resent update I have experienced multiple issues, of which I will describe one in this post.
PCMan does not respond. I cannot open it with the shortcut on the task bar, nor in the Accessories tab of the launcher.
Typing pcmanfm-qt in the command line has no result (no file manager window, or command line output).

There also is no image on the desktop. and right clicking the desktop gives me the openbox menu. Non of the menu options work, I get

“Failed to execute child process “lxsession-default” (no such file or directory)”

I tried to reset the desktop wallpaper image in ~/.config/pcmanfm-qt/lxqt/settings.conf (as was suggested in a post on askubuntu but that didn’t help.
The following is system info and syslog:

Providing the askubuntu link may have helped, this does reminds me of a query there that had me do some testing & respond, and it caused the condition you describe (on Lubuntu, Debian & openSUSE etc as LXQt issue; pcmanfm-qt reached a point where it ‘crashed too often’ & stopped working; it was reported upstream who have fixed that issue on LXQt 15.1, alas doesn’t help those of us on older versions…)

I’d check for errors in the .conf files to ensure they are perfect, then you’ll need to logout & login again for `pcmanfm-qt to restart properly and test to see if it’s fixed itself. When the .conf file is correct the issue disappears (in my experience if it’s the issue this reminds me of).

here is the ask ubuntu link: https://askubuntu.com/questions/1238736/the-pcmanfm-qt-is-dead-on-my-lubuntu-20-04
I was only allowed to post 2 links as I am a new poster.
Thanks for the tips.
I will go through the .conf file again to make sure.

1 Like

So, it was not the .conf after all. But was my NoMachine. I was controlling this desktop remotely via NoMachine. Connecting to a monitor to the PC and rebooting brought up LXQt just fine, however the remote session still cannot open PCMan, has a black wallpaper, and has greyed out openbox options on desktop right-click.
I suppose I should open a new post for that issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.