Trouble installing Lubuntu 20.04

When booting from the USB flash drive on my Lenovo C365
I get the error:
Initramfs unpacking failed: Decoding failed
Previously I installed Ubuntu 20.04, which went fine.
So I can boot that, and access grub and have disabled Secure Boot in the settings.
I booted the Ubuntu install USB and it still runs “live” without any trouble.
Has anyone seen this on the new version?


Have you tried waiting for a little while when the error message is shown, to see if it is actually blocking your boot?

Thanks for the suggestion.
Yes, I have waited overnight:
it just sits there on that error forever.
There is some more text / errors after it like:
“Failed to execute /init (errror -2)
Kernel panic - not syncing: No working init found.”
And helpful tips like:
Try passing init= option to kernel.
Although I’m not sure where I would do that:
by editing the files on the USB flash drive before booting from it?
I’m assuming the error indicates a larger problem than the specifics of it describe, right?


I very doubt much I’ve seen it, but did you verify the ISO after download?

If you did verify the checksum of the ISO, then I’d next check out the write to your install media. Given it won’t boot on that box, I’d try booting it on another box and try using it in ‘live’ mode. Lubuntu 20.04 will to a scan of the install media (don’t skip that) and it’ll verify the write of the ISO to your cd/dvd/thumb-drive for you before it runs.

If it fails to boot on this second box, I would safely assume the write to your media was faulty, and you could try on a third box (which won’t boot either if faulty) but I’d just go and re-write the ISO to media, or check your media itself (it’ll likely just be a bad write).


Yes, I verified with shasum and the download (from was OK.
When it starts to boot I get a welcome screen to select the language, then:
Start Lubuntu - which stops quickly on the initramfs error
Start Lubuntu (safe graphics) - haven’t tried this: assuming the initramfs is not graphics related
Test memory - runs Memtest86 to test physical RAM, which passes OK
Boot from first hard disk - this is where the Ubuntu 20.04 is installed so assuming that won’t help
I booted a different computer from the same USB flash drive and it fails with the same initramfs error.
I will burn the same ISO file to a different USB flash drive and retry.

Thanks for your help!,

yes, the USB flash drive I used initially was defective,
although Rufus repeatedly showed it completed successfully
(I agree with others I saw suggesting a verify feature would help),
so the initramfs error may indicate that. .
Thanks to both of you for your helpful suggestions,

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.