Touch screen does not rotate automatically

Hello, on the Alcatel Plus 10 Tablet, 2x1, which came with Windows 10, Lubuntu 24.04 LTS is the only distribution that I have managed to install successfully, one problem is that the screen rotation, vertical to horizontal, is not executed automatically and when done manually The touch function acts in wrong areas of the screen. In Windows 10 the screen rotation and response worked very well.

Has anyone had this same problem? Any solution?

Thank you so much

As far as I know, no one on the Lubuntu Team does any testing or development with tablets. Additionally, there are not many requests for help with them (although they’re increasing slightly). That said, it’s probably safe to say that they are poorly supported.

That said, I don’t have anything else to add to this except this topic from before where someone at least seems to have worked out a reasonable solution to manual rotation, albeit in an earlier version, but it should still work.

2 Likes

I can’t help, but will comment.

I booted a device I own & use for some tasks, it being

samsung 700t1c-p10aat (i5-3317u, 4gb, 3rd gen.core.intel.graphics.4000)

That device of mine still has 22.04 LTS on it, and my preferred desktop on that thing is actually the GNOME desktop provided by Ubuntu Desktop (I just find GNOME easier with the touch screen; which I actually use on that device as I don’t have a real mouse connected to it; sure the install was a Lubuntu install and I still have Lubuntu/LXQt installed (Xubuntu/Xfce too), I just use GNOME by default with my install being a multi-desktop install).

I logged out & switched to a Lubuntu/LXQt session, and logged in. On that device

  • screen rotation was not automatic on either GNOME or LXQt on default sessions (I’d expect identical with Xfce but didn’t try); I have no idea if its possible, as if it was I’d disable it anyway (if it was default in GNOME; I’ve changed that default; I forget)
  • on manual rotation however, the touch screen was reacting as I’d expect in GNOME, where as in LXQt the touch was reacting as you describe.

I rarely use touch screens (I like my screens clean), but on that one device I actually do use it, and for me I prefer using GNOME. I’ve always found LXQt too finicky wanting precision in clicks which just aren’t possible with my fat fingers.

I’ve never explored why the touch doesn’t revert… but I don’t change orientation & haven’t wanted to either. An option if you really need it maybe switching desktops, to a heavier desktop that includes that functionality. Sorry I don’t have any useful advice with Lubuntu/LXQt.

1 Like

Thank you very much, I will take your opinion into account.
Good day.

I will find out how to install the gnome desktop in Lubuntu 24.04 LTS.

Hello, I appreciate your recommendation.
Good day

You would have a much easier time just installing Ubuntu which has the GNOME desktop.

2 Likes

FYI: I would have just used sudo apt install ubuntu-desktop to ensure I got everything…

There maybe better LXQt answers, but sorry I don’t know, and never explored that. On that device and its small screen, GNOME just seemed to make sense to me for that device.

1 Like