Too many unresponsive sites/hard re-starts: what web browser to try next?

I have a Dell Inspiron 1545 laptop circa 2009. I was using 17.10 and Chromium (or Chome–not sure) previously, but recently installed 20.04. I have been trying to use the Firefox that came installed with Lubuntu 20.04. However, I have been having a lot of issues with extremely slow websites or websites that make my computer completely freeze.

First was YouTube–I can only have 1 or 2 tabs open with YouTube or everything freezes, and even with 1 tab open, sometimes the page takes a really long time to finish loading. I was told on another forum that maybe this is because Firefox doesn’t have hardware acceleration like Chrome.

Then it was Microsoft Teams that started making everything freeze. Then Microsoft’s Hotmail. And just now, I tried to use Google Maps, and as soon as I tried to zoom in, everything froze. I waited 10 minutes and cleaned my dirty dishes in the kitchen, but still nothing.

This is all too much now, and very unfortunate, and I need to change something so it stops happening. I don’t see how it can be the hardware because with 17.10/Chromium, I didn’t have these issues on this same hardware.

My guess is that it is Firefox. I would like to have made FF work for me, but I am going to try some different browser now.

Does anyone have any recommendations for the next browser I should try to stop these freezing issues?

Thank you very much.

I am using Microsoft Teams on Lubuntu 19.10 and I don’t have any problems.
I am using Firefox on Lubuntu 19.10 and can watch video streams without any problems.

If you have problems, either they are related to your hardware or you might have some errors.

You can check with htop the cpu and RAM usage of firefox.
With journalctl -b -p err or journalctl -b -p warning you can check, if there are some logged errors or warnings.

On 20.04 you can install chrome (from an external repository) or chromium (as a snap) and see, if it happens as well. I guess, you will experience the same behaviour.

Hardware acceleration with Firefox is possible, but currently works only with Wayland. For more details have a look at the blog from Martin Stransky (Red Hat). And the hardware acceleration of Chrome does not really work on every system.

Another problem could be an installed firefox addon. Please check also the behaviour with deactivated addons.

2 Likes

I use Firefox almost exclusively. I only recently installed chromium to test something out. I don’t really use it much but it is there. Chromium is a snap now as opposed to the Debian package that 17.10 had. I don’t think that is necessarily a good or bad thing, I just point out that it is different.

I am not sure how much RAM you have installed in that but I find that with only a few tabs open and using Firefox my system idles at about 1.8GB of RAM used out of the 8GB installed.
There is great debate on utilizing swap, I won’t enter into that but I can say if your machine is low on resources having a swapfile can be helpful.

How do you measure the RAM usage of Firefox?
The 1.8 GB RAM is the memory Firefox actually uses and needs to run? Or is it the virtual RAM size? Or reserved for Firefox to improve performance, but not needed? How much of it is shared memory?

The Linux memory management is quite interesting, but highly complex. And it depends on the hardware and on the running processes at the moment.

In Firefox, you can see with about:performance which tab and add-on uses how much RAM.
And with F12 you can open the developer tools, where you can see other informations.

Slow web pages might be also related to problems with the web server or the network.

I personally use Chromium, no particular reason but I find it better than Firefox, no problems browsing in Lubuntu 20.04 with either, it might be your PC.

One thing I always do is to install an Ad blocker, that helps with browsing.

Yes, you are correct. There are many variables and everyone uses their system differently.

That number was the overall system utilization, I didn’t pick out what Firefox was actually using. The point I was trying to make was that utilization jumps significantly with the browser and more specifically web applications. If the overall system is a little short you can experience symptoms similar to the OP.

As you pointed out there are many other factors that could be in play.

1 Like

I will read the tutorial, but I hadn’t addressed that because I thought in current distributions of *buntu, the swap file is automatically managed by the OS…

On another forum, one user suggested that I reduce the “content processes” in FireFox from default of 8 to 2. I did that, and today I got through work using Microsoft O365 Teams website without any problems. It might be a coincidence. I don’t know.

Here is some information from inxi -F command:

System:    Host: ptr Kernel: 5.4.0-29-generic x86_64 bits: 64 Desktop: LXQt 0.14.1 
           Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Machine:   Type: Portable System: Dell product: Inspiron 1545 v: N/A 
           serial: <superuser/root required> 
           Mobo: Dell model: 0G848F serial: <superuser/root required> BIOS: Dell v: A07 
           date: 05/13/2009 
CPU:       Topology: Single Core model: Intel 585 bits: 64 type: MCP L2 cache: 1024 KiB 
           Speed: 2161 MHz min/max: 1000/2167 MHz Core speed (MHz): 1: 2161 
Graphics:  Device-1: Intel Mobile 4 Series Integrated Graphics driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express (CTG) v: 2.1 Mesa 20.0.4 
Audio:     Device-1: Intel 82801I HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-29-generic 
Network:   Device-1: Marvell 88E8040 PCI-E Fast Ethernet driver: sky2 
           IF: enp9s0 state: down mac: 00:25:64:3e:9d:33 
           Device-2: Broadcom and subsidiaries BCM4312 802.11b/g LP-PHY 
           driver: b43-pci-bridge 
           Device-3: Dell Wireless 365 Bluetooth type: USB driver: btusb 
           IF-ID-1: wlan0 state: up mac: 00:22:5f:bf:3f:a4 
Drives:    Local Storage: total: 149.05 GiB used: 7.74 GiB (5.2%) 
           ID-1: /dev/sda vendor: Seagate model: ST9160310AS size: 149.05 GiB 
Partition: ID-1: / size: 145.71 GiB used: 7.74 GiB (5.3%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3800 
Info:      Processes: 142 Uptime: 1h 13m Memory: 1.90 GiB used: 774.0 MiB (39.7%) 
           Shell: bash inxi: 3.0.38

Hi, I have tried Falkon browser (https://www.falkon.org/) on an old netbook (Samsung N150, 1GB RAM) and it works very fast to watch youtube videos and for many other websites. The only issue to keep in mind is that with Falkon you can’t watch Netflix or other streming site that use HTML5.
I hope that this help you

3 Likes

Thanks that looks interesting!

1 Like

I’m sorry, it’s not the HTML5 that lacks in Falkon, it is the “widevine content decryption module”.

P.S. I would really like Falkon to be our default browser. In the past it’s been a little too crashy for my tastes but I haven’t looked at it recently.

1 Like

Yes, it’s a really good option. I have installed on a lenovo G550 notebook too, an dispite Chrome and Firefox, Falkon is the only one without video problems (on youtube for example). In google chrome, for instance I see a pixel band that cross out my screen (z shaped) and using firefox I have little lines that interrupt the video streaming all the time.
So, Falkon is a good alternative for almost all my purpouses, but if I want to watch Netflix I need to change to Firefox.
Maybe we can advise Falkon developers to include Widevine content decryption module and addapt it as a full purpouse browser.
Thanks for taking my replies into account.

Aaaaaaaactually it looks like this is possible. It may more be the issue that the version Ubuntu provides comes without it installed, which wouldn’t be surprising because it requires proprietary (not open source) codecs. Dig a bit deeper and you’ll find you basically need to hack it by ripping the plugin out of Chrome. The reason for this stupidity? Because Google is a power-wielding bully.

1 Like

Thanks for the info!! I wont be able to recompile my browser, to do that I need to learn a lot more about programming and linux OSs. If you have an idea where can I find a good course to learn this, it would be grate!!
Thanks again for your help!!

Use the source, Luke.

4 Likes