The package system is broken

Hello everyone,

I wonder if you could help, I get the error message:
The Package System is broken
python3-apt: Depends: python3 (>= 3.6~) but 3.6.7-1~18.04 is installed
Depends: python3:any (>= 3.3.2-2~) but it is a virtual package
Depends: libc6 (>= 2.14) but 2.27-3ubuntu1 is installed
Depends: libgcc1 (>= 1:3.0) but 1:8.4.0-1ubuntu1~18.04 is installed
Depends: libstdc++6 (>= 5.2) but 8.4.0-1ubuntu1~18.04 is installed

You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies.
python3-apt : Depends: libapt-inst2.0 (>= 1.6.5~) but 1.6.1 is to be installed

Package System

I have tried to fix this by typing the commands below into the console:

sudo apt install -f
sudo apt --fix-broken install python3-apt

sudo apt-get autoremove
sudo apt-get install -f

But nothing has resolved the issue.
Could someone please help?

How did this come up?

Lubuntu 18.04 is asking for a software update.
The error occurs when I start the update:

Updater

I’m particularly confused by this because 1.6.6ubuntu0.1 is in the security archives. I would try a sudo apt update and re-do your attempts to fix it.

Hi wxl,

thank you for your advise, I did the following:

sudo apt-get update
sudo apt-get upgrade

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies.
python3-apt : Depends: libapt-inst2.0 (>= 1.6.5~) but 1.6.1 is installed

sudo apt --fix-broken install

and I got:

Preparing to unpack …/libapt-inst2.0_1.6.12_amd64.deb …
dpkg: error processing archive /var/cache/apt/archives/libapt-inst2.0_1.6.12_amd64.deb (–unpack):
fgets gave an empty string from ‘/var/lib/dpkg/info/libapt-inst2.0:amd64.triggers’
Errors were encountered while processing:
/var/cache/apt/archives/libapt-inst2.0_1.6.12_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Do you have any idea how to fix this?
Thank you in advance!

I would suggest filing a bug,

Maybe a better idea: install 20.04 instead and stop dealing with old software!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.