Test installing Lubuntu Focal into an nvme drive


nvme drives, SSD drives connected via PCI Express, are getting more common becasue they can be faster than SSD drives connected via SATA.

I installed such drive, an m2 stick via a PCI Express card into my workstation, a Lenovo Thinkstation C30, that I bought second hand (refurbished). This solution [with an m2 stick via a PCI Express card] is much cheaper than buying a computer that is new enough to boot from nvme.

In this configuration it is not possible to boot directly into the nvme drive. The BIOS/UEFI system does not recognize it. But using Ubiquity in Xubuntu Focal I can make a boot partition in a SATA drive and from there boot into the root partition in the nvme drive. I can also run sudo update-grub from my main operating system in the SATA-SSD to get a working menuentry.

I tested the installer Calamares of Lubuntu Focal. It does not recognize the nvme partition, and I did not see any [intuitive?] way to put the boot partition in another drive and the root partition in the nvme drive. Maybe there is a way, but direct testing in a computer that can boot from nvme is much better.

Call for help to test installing into an nvme drive

So if you have a computer, that can boot from an nvme drive, and you can it use for testing (including editing and/or overwriting the nvme drive), please let me know, and we can talk about details of the testing.


Ubuntu Development Forum: Can you test booting into an nvme drive?

1 Like

Now things are working as they should. I have access to a laptop with an nvme drive, a Lenovo V130, and what I wanted to test has been veriified.

  • Calmares in today’s daily iso file can install Lubuntu Focal into the nvme drive. There were problems with earlier versions, but it works now.

  • mkusb can install a working persitent live drive into the nvme drive.

1 Like

Sorry I didn’t reply to this, but I did take some interest in it, as I have seen some support issues that all seemed to have problems with such a drive. Since Eoan shipped with 3.2.14-0ubuntu2 and Focal currently has 3.2.14-0ubuntu3, my guess is it’s that Ubuntu-specific patch that solved the problem, but that’s a no change rebuild. So I’m a little confused how it’s fixed, but glad to hear it :man_shrugging:t3: