Taskbar (panel) duplicated, help!

I have tried to fix this by disabling lxqt-panel autostart and everything but I can’t get it to work! I am new to linux so any help is appreciated.screen here is an image of it. This also makes menu invisible (i can still click on things). I haven’t really installed anything important, I could reset the whole system.

My main panel is the left one, I don’t want the bottom one because my plank is there

The manual page on configuration of the panel can be found at

https://manual.lubuntu.me/stable/5/5.1/lxqt-panel.html

If you right-click on the panel, I would expect to see a “Remove Panel” option, however on a panel filled with many items, you need to right-click it between widgets/items otherwise you’ll be right-clicking the panel widget itself. For a better explanation, I’d suggest reading the “Customizing” section of the manual link I provided.

the problem is, I’d have to guess where the different options in the panel options are. Every menu is invisible for me. Is there a terminal command?

I would really like to get this solved, but I will now just reinstall and start from fresh. If this happens in the future I would like to know what to do though.

My guess from your description is, you’re using a theme intended for a different (non-LXQt) desktop, and I’d correct that first, and the issue you describe should be easily fixed as I suggested last response.

To change themes, please look up
https://manual.lubuntu.me/stable/3/3.2/3.2.2/appearance.html

Panel configuration can be found at ~/.config/lxqt/panel.conf but I wouldn’t suggest playing with that. Other than downloading and trying to use badly created/tested themes, I can’t imagine what you’ve done, but I’d try and reverse that first (ie. fix the invisible menus).

If you’re like me and use commands; command history provides clues of what you did (I also leave loads of comments including dates so there is a trail should I need to reverse changes).

Hi, I am not experienced Lubuntu user but I had similar issue. What worked for me if I remember:

  1. I’ve created second user “user2”, login as user2 and check that desktop is ok for user2
  2. copied/replaced ~/.config/lxqt/panel.conf` from user2 to my account and check/fix rights on the file
  3. reboot
1 Like