Sudo apt autoremove

When I install something using apt it tells me that “The following packages were automatically installed and are no longer required:” Then 320 packages that look like most of my install followed by “Use ‘sudo apt autoremove’ to remove them.”

Not sure how I got into this situation or how to rectify it…

You’ve not provided any release details, so I’ll pick kinetic (22.10).

The manual describes the command apt autoremove as

autoremove (apt-get(8))

autoremove is used to remove packages that were automatically installed to satisfy dependencies for other packages and are now no longer needed as dependencies changed or the package(s) needing them were removed in the meantime. You should check that the list does not include applications you have grown to like even though they were once installed just as a dependency of another package. You can mark such a package as manually installed by using apt-mark(8). Packages which you have installed explicitly via install are also never proposed for automatic removal.

You’ll also find varies questions on sites that also describe it (eg. here.

You’ll have no negative consequences to your system if you’re only using official or well managed repositories for your software. Problems occur only with 3rd party sources that tend to be lazy and don’t package for a specific release creating one repository that can be used by multiple OSes or releases.

In your case; I’d go to terminal and type in

sudo apt autoremove

and then scan the packages that are listed; I’d expect I’d know why they are there, or where they came from (I review any sources I add to my system before I add them). If I was unsure of any, I’d not let the removal of packages occur (ie. it asks for permission first; I don’t give it) and explore why they’re being listed before I proceeded.

You didn’t provide a list of these packages, as this with release detail is required to review in my opinion.

Personally, I perform package upgrades three times per day, and the full-upgrade I use is always followed by an apt autoremove and apt autoclean as I don’t want packages to accumulate waiting for removal; as I may not remember why they’re there (with 320 in your queue, either you never run it, or you’ve added a bad source to your system I suspect, but I’m guessing based only on what you provided).

FYI: to view the manual page on your system, use man apt


Thanks for that. I’m actually using 22.04. Below is the output from sudo apt autoremove… I’m thinking I’d destroy my installation if I removed that lot!

The following packages will be REMOVED
2048-qt acpi-support acpid alsa-base apport apport-symptoms apt-config-icons-hidpi
apt-config-icons-large apt-config-icons-large-hidpi aptdaemon arc-theme bluedevil bluez
bluez-cups bolt breeze-cursor-theme caca-utils chafa compton compton-conf dc fonts-kacst
fonts-kacst-one fonts-khmeros-core fonts-lao fonts-lklug-sinhala fonts-noto-cjk
fonts-sil-abyssinica fonts-sil-padauk fonts-symbola fonts-thai-tlwg
fonts-tibetan-machine fonts-tlwg-garuda fonts-tlwg-garuda-ttf fonts-tlwg-kinnari
fonts-tlwg-kinnari-ttf fonts-tlwg-laksaman fonts-tlwg-laksaman-ttf fonts-tlwg-loma
fonts-tlwg-loma-ttf fonts-tlwg-mono fonts-tlwg-mono-ttf fonts-tlwg-norasi
fonts-tlwg-norasi-ttf fonts-tlwg-purisa fonts-tlwg-purisa-ttf fonts-tlwg-sawasdee
fonts-tlwg-sawasdee-ttf fonts-tlwg-typewriter fonts-tlwg-typewriter-ttf
fonts-tlwg-typist fonts-tlwg-typist-ttf fonts-tlwg-typo fonts-tlwg-typo-ttf
fonts-tlwg-umpush fonts-tlwg-umpush-ttf fonts-tlwg-waree fonts-tlwg-waree-ttf fwupd
fwupd-signed genisoimage gir1.2-udisks-2.0 gnome-accessibility-themes gnome-themes-extra
gnome-themes-extra-data gstreamer1.0-gtk3 gtk2-engines-murrine gtk2-engines-pixbuf
haveged htop inputattach jp2a kcalc kde-cli-tools kde-cli-tools-data kde-config-updates
kde-style-breeze kerneloops language-selector-common laptop-detect liba52-0.7.4
libabw-0.1-1 libappstreamqt2 libaribb24-0 libcddb2 libcdr-0.1-1 libchafa0 libconfig9
libcupsimage2 libdca0 libdvbpsi10 libe-book-0.1-1 libebml5 libepubgen-0.1-1
libetonyek-0.1-1 libev4 libfaad2 libflashrom1 libfm-data libfm-gtk-data libfm-gtk4
libfm-modules libfm4 libfreehand-0.1-1 libftdi1-2 libfuse2 libfwupd2 libfwupdplugin5
libgcab-1.0-0 libgles2 libgutenprint-common libgutenprint9 libhavege2 libixml10 libjcat1
libkate1 libkf5attica5 libkf5bluezqt-data libkf5bluezqt6 libkf5itemmodels5
libkf5networkmanagerqt6 libkf5newstuffcore5 libkf5notifyconfig-data libkf5notifyconfig5
libkf5pty-data libkf5pty5 libkf5sane-data libkf5sane5 libkf5style5 libkf5su-bin
libkf5su-data libkf5su5 libkf5syndication5abi1 libkworkspace5-5 liblirc-client0
liblua5.2-0 libmad0 libmarkdown2 libmatroska7 libminiupnpc17 libmpcdec6 libmpeg2-4
libmspub-0.1-1 libmwaw-0.3-3 libnatpmp1 libntfs-3g89 liboath0 libodfgen-0.1-1
libopenmpt-modplug1 libpackagekitqt5-1 libpagemaker-0.0-0 libplacebo192
libprotobuf-lite23 libproxy-tools libqapt3 libqapt3-runtime libqrencode4 libqt5designer5
libqt5help5 libqt5test5 libreoffice-base-core libreoffice-calc libreoffice-draw
libreoffice-gtk3 libreoffice-impress libreoffice-math libreoffice-qt5 libreoffice-writer
libresid-builder0c2a libsbc1 libsdl-image1.2 libsdl1.2debian libsidplay2 libsmbios-c2
libsnapd-qt1 libspatialaudio0 libssh2-1 libu2f-udev libupnp13 libva-wayland2
libvisio-0.1-1 libvlc-bin libvlc5 libvlccore9 libvncclient1 libwhoopsie0 libwpd-0.10-10
libwpg-0.3-3 libwps-0.4-4 libxatracker2 libxcb-xv0 libxcvt0 libxfont2 libxvmc1
linux-sound-base lp-solve lubuntu-default-settings lubuntu-grub-theme
lubuntu-update-notifier lxqt-admin lxqt-admin-l10n memtest86+ mscompress muon neofetch
nm-tray nm-tray-l10n noblenote oathtool pass pass-extension-otp pastebinit pcmciautils
picom plasma-discover plasma-discover-backend-fwupd plasma-discover-common
policykit-desktop-privileges printer-driver-brlaser printer-driver-c2esp
printer-driver-foo2zjs printer-driver-foo2zjs-common printer-driver-gutenprint
printer-driver-m2300w printer-driver-min12xxw printer-driver-pnm2ppa
printer-driver-ptouch printer-driver-pxljr printer-driver-sag-gdi printer-driver-splix
pulseaudio-module-bluetooth pwgen python3-apport python3-aptdaemon python3-click
python3-colorama python3-dbus.mainloop.pyqt5 python3-debconf python3-defer
python3-problem-report python3-pyqt5 python3-pyqt5.sip python3-software-properties
python3-systemd python3-xkit qapt-deb-installer qml-module-org-kde-bluezqt
qml-module-org-kde-kcoreaddons qml-module-org-kde-kio qml-module-org-kde-newstuff
qrencode qtpass quassel quassel-data rfkill sbsigntool screengrab sddm
sddm-theme-lubuntu secureboot-db skanlite software-properties-common
software-properties-qt spice-vdagent toilet toilet-fonts transmission-common
transmission-qt tree ttf-ancient-fonts-symbola ubuntu-drivers-common
ubuntu-release-upgrader-qt unattended-upgrades update-notifier-common usb-creator-common
usb-creator-kde vlc vlc-bin vlc-data vlc-l10n vlc-plugin-access-extra vlc-plugin-base
vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-svg
vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization whoopsie
x11-apps x11-session-utils xclip xcvt xfonts-base xfonts-efont-unicode
xfonts-efont-unicode-ib xfonts-scalable xinit xinput xorg xserver-common xserver-xorg
xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput
xserver-xorg-input-wacom xserver-xorg-legacy xserver-xorg-video-all
xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl
xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware zsync
0 to upgrade, 0 to newly install, 320 to remove and 1 not to upgrade.
After this operation, 544 MB disk space will be freed.

Well that’s strange. Looking through my the installation history in the Muon package manager I noticed that the metapackage “Lubuntu desktop” had been removed on the 7th October. I certainly wouldn’t have done that…

Anyway, reinstalling that metapackage seems to have solved the problem. I now only have 3 files to remove via autoremove.


I’ll report on what I’d do in your shoes, but sorry I don’t use Muon beyond testing it to ensure it works (my preference is terminal, and if I want a package manager it’s aptitude for me usually)

I’d explore your apt package logs, me I’d likely use the command

view /var/log/apt/history.log

If you’re not familiar with unix/POSIX searching (or vi / vim which uses it too) you’ll be out of place here, but I’d type something like


to search for “lubuntu-desktop” and possibly press ‘enter’ IF it didn’t find the one I wanted so I could hit N to jump to the next reference in the log. You’ve already got a date, which will help find the entry you’re looking for.

The reason I’d look at these logs is I’d want to explore the reason/command that caused the removal of the package, was it because you’d installed a 3rd party package that conflicted which apt resolved by removing lubuntu-desktop as a solution? or just a careless mistake was made (we all make them!). I’d like to find the reason, or possible reason before I ignored it. This method will largely present the detail in a more complete manner (in my opinion anyway)

If your situation is solved, none of this matters. I opened muon and had a look and it concentrates of package versions without all details. Maybe what I provided will be of benefit.

In all the years I’ve been using Linux I’ve never used that method of searching. Really neat! I must get back to learning vi…

Anyway, I found the entry for that date:

Start-Date: 2022-10-07 19:15:44
Install: libfuse2:amd64 (2.9.9-5ubuntu3, automatic), fuse:amd64 (2.9.9-5ubuntu3)
Remove: ntfs-3g:amd64 (1:2021.8.22-3ubuntu1.1), xdg-desktop-portal-kde:amd64 (5.24.6-0ubuntu
0.1), lubuntu-desktop:amd64 (22.04.3), gvfs-fuse:amd64 (1.48.2-0ubuntu1), plasma-discover-ba
ckend-snap:amd64 (5.24.6-0ubuntu0.1), fuse3:amd64 (3.10.5-1build1), xdg-desktop-portal:amd64
End-Date: 2022-10-07 19:17:17

Not sure why it wanted to remove ntfs-3g ( I reinstalled it). The only things outside of the repo I installed were Eddie ( Openvpn gui prog) and Spideroak (Cloud server) I was fiddling with a terminal prog called scrcpy (Copies android phone screen via usb to display) the day before but thats in the repo. Seems to be a lot of ‘fuse’ activity. Different versions etc…

Anyway, everything seems to be working fine. Thanks for your help.


I run into this exact same situation if I remove any application that comes with Lubuntu by default. For instance, I used to remove the Bluetooth stack on my systems pretty much all the time, which led to the mess you’re describing. I’m not exactly sure what package you uninstalled, but that’s almost certainly how you got there.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.