[SOLVED] Focal and 5.8 HWE kernel woes

NOTE: This issue looks to be solved. Please follow links to this Ubuntu Discourse post


Background

There are normally two kernel tracks with LTS releases:

  1. The GA (General Availability) track (linux-generic) which should be supported throughout the lifecycle of the release.
  2. The HWE (Hard Ware Enablement) track (linux-generic-hwe-*) which provides updates intended to give more support to newer hardware. They come in little spurts, starting with the second point release (as per the wiki).

Up until Focal, the default on all releases installed with the initial ISO or a .1 ISO was to use the GA kernel. With Focal, on Ubuntu Desktop, the HWE kernel became the default as per the wiki and the release notes.

The problem

This change is all fine and dandy and more than likely, welcome. Unfortunately, a few automated tests returned false positives and the kernel couldn’t be rolled back because that would mean dropping important security updates.

The end result of this is that there are a variety of packages that needed to be updated/tested in concert with the new kernel that were failing to work correctly. This includes:

  • VirtualBox
  • anything using dkms
  • a variety of drivers including:
    • graphics
    • networking
    • audio

Enter Lubuntu

Thankfully, we did not include the HWE kernel by default (nor did any other flavor as far as we know), so this problem should not affect Lubuntu installations by default.

However, there are two ways in which it can affect your installation:

  1. If you installed Ubuntu Desktop and then installed the lubuntu-desktop metapackage, which is not even something we recommend.
  2. If you explicitly installed the HWE kernel.

You can run uname -r to see what kernel version you’re on. If dpkg -l | grep hwe returns anything, that’s probably a bad sign, too.

The solution

As described in the post from the Ubuntu Team, several bugs are already fixed and they are actively working on others. The suggestion is to stick with the kernel you have since this should provide the best possible hardware support.

Know that the people involved are working feverishly to get this resolved. No one wanted this to happen. Let’s not forget the philosophy behind the Ubuntu project’s name and cut everyone a little slack. :slight_smile:

The workaround

In the event that you are affected and staying on the current kernel is not feasible, these are possible workarounds to consider:

  1. Install the GA kernel, make sure it works and uninstall the HWE kernel. Not tested, so not recommended per se. Also, as mentioned in the post from the Ubuntu Team, this may result in diminished performance.
  2. Assuming the 5.4 and 5.8 kernels are installed, swap your GRUB_DEFAULT to the older kernel. That would involve something like adapting this solution or using the grub-customizer package which is a GRUB config GUI. Unfortunately, it’s GTK, so it will likely pull in some extra dependencies, but it’s very easy to use.

FAQ

  • What’s wrong with the 5.8 kernel?
    • Believe it or not, nothing. The 5.8 kernel exists in Groovy and everything’s working fine. The issue is with compatibility of other components. They all need to work together as a cohesive whole.
5 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.