Set Lubuntu to autologin after installation

I’m posting this here because it took me a long time to successfully research and do this, and I hope other users will be able to find this answer quickly by searching the forums…

I installed Lubuntu, but I didn’t check
Login automatically without asking for a password
during the installation process.

After installation, I wanted to change Lubuntu to auto-log-in, so I didn’t have to enter a password every time I booted the computer. I searched for a long time and went down a few wrong paths due to outdated information on the Internet.

Lubuntu 22.04.1 uses SDDM for the log-in screen (not LightDM, not anything else; it’s SDDM). If you search the manual for SDDM, it will tell you how to disable auto log in, but not how to turn it on. To turn it on, I did the following, which is working for me…

First, open the SDDM configuration file.
sudo nano /etc/sddm.conf

When I opened mine, it had

[Autologin]
Session=Lubuntu

Autologin options are described in this document:

Using the arrow and enter keys on the keyboard, move the text cursor around and type until your sddm.conf has the User, Session, and Relogin options specified.

[Autologin]
User=<your user name>
Session=Lubuntu
Relogin=true

(For User, make sure you use the log-in name you specified during installation, not the “Full Name” you specified at installation.)

After setting the options, choose Ctrl+O, which is described in the Terminal as
^O Write Out

The Terminal will ask you to confirm the “File Name to Write:” Hit the Enter key and you are finished. When you re-start, your Lubuntu should boot up directly to the desktop, bypassing the log-in page. If it doesn’t and you can’t log in, I guess you are out of luck, but the above worked for me!!!

If any better users have comments on this process, please do post here, thanks.

4 Likes

Nice tip :+1:

(Usually you don’t need the Relogin line (default false).
Relogin-true will relogin immediately after you logout. So you will never see the login screen.)

3 Likes

Hey Chris and humpty this worked.

Thanks :grinning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.