SDDM Virtual Keyboard?

I’ve recently installed Lubuntu 19.10 and got everything almost fully working, however I’m currently having to use autologin because the login screen doesn’t display any virtual keyboard and I’m on a tablet.

I have onboard installed, and I have also tried to install qtvirtualkeyboard (via apt-get install qtvirtualkeyboard*) and editing the sddm.conf file, however all I managed to do was get the screen to go black with no virtual keyboard appearing.

I have used KDE and SDDM and know that on the tablet the black screen part is normal, but usually accompanied with the keyboard appearing over the black screen so I wondered if I’ve missed an option etc.


Hi whoozzem,

I’m a new Lubuntu user for a couple of days. I get SDDM flickers and need to install a different theme compatible with my old hw. I have seen some desktop lacks, instead it’s a vibrant project and I enjoy it. I am on Lubuntu 20.04 beta and I have the same problem as you. I don’t use virtual kbd but I found the following:

$ grep -i virtualkeyboard /var/log/* | tail -10
/var/log/syslog:Mar 23 11:03:00 icetwr sddm-greeter[7769]: qrc:/QtQuick/VirtualKeyboard/content/InputPanel.qml:125:5: Type Keyboard unavailable
/var/log/syslog:Mar 23 11:03:00 icetwr sddm-greeter[7769]: qrc:/QtQuick/VirtualKeyboard/content/components/Keyboard.qml:37:1: module "Qt.labs.folderlistmodel" is not installed

qml-module-qtquick* is installed, not so qml-module-qt-labs-folderlistmodel and should be.
Then you’ll find a drag button on the login screen to show the keyboard.

Regards. o/

1 Like

Thanks for the response, that worked perfectly.

I don’t actually get a drag button but clicking the password input box brings it up.

Would be nice if there was a setting in the /etc/sddm.conf file to disable the black screen under the keyboard but I guess you can’t have everything :slight_smile:

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.