Screenshot "Capture an area of the screen" with 2 monitors

I have a monitor (1920x1200) and tv (4096x2160).
My desktop is the monitor and the tv is set to “This screen extends another display and x is 1920”.
When I run “Screenshot” (press the prtsc key) and select “Capture an area of the screen” my desktop is cloned to the 0,0 on the tv.

which lubuntu version?

It is version 19.04.

I assume then that you are using lximage-qt for screenshot (the default in 19.04). Try screengrab, is our (and LXQt) default screenshot utility for 19.10.- sudo apt install screengrab

screengrab works, thanks.

I noticed a problem when capturing an area of the screen the message says to press any key or click the middle or right mouse button.
The scroll bar is supposed to work as my middle mouse button when clicked.
It does nothing after selecting an area of the screen.
Clicking the right mouse button resets the selected area to nothing.

That issue was noted and fixed. Unfortunately it hasn’t been included in the version that is in the Ubuntu archive for 19.04.
The tl;dr instructions should read “Click and drag to draw a rectangle, then double click or press Enter to take a screenshot.”

Great, thanks that works.

I upgraded to 19.10 and screengrab has the same problem.
I discovered an interesting piece of information.
It has the problem if I run it by pressing the prtsc button on the keyboard (it copies my desktop to the tv and only allows capture area of the screen there).
It works if I run it from the menu.
It is only “Capture an area of the screen” that has this problem.

screengrab has several options, and the one use in the shortcut is w/o option. You can changee it if you want in Menu->Preferences->LXQt Config -> Shorcuts.
Options:
-h, --help Displays this help.
-v, --version Displays version information.
-f, --fullscreen Take a fullscreen screenshot
-a, --active Take a screenshot of the active window
-r, --region Take a screenshot of a selection of the screen
-m, --minimized Run the application with a hidden main window

Where do I look to see if there are any options passed from the menu and if there any options passed by pressing the prtsc key?

Menu->Preferences->LXQt Config -> Shorcuts.

Interesting.
The shortcut is to “lximage -s”.
I changed the shortcut to “screengrab” and it works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.