Screensaver does not want to open in Lubuntu 22.10

steps to reproduce
open the main menu, select Preferences and select Screensaver

the main menu disappears

the window of Screensaver should appear

It seems to be that it is a Lubuntu problem, and not a LXQt problem:


Yeah we know it’s a problem, it was mentioned in our issue tracker

Our intention is to explore why, come up with a fix we can SRU into kinetic so users download the fix automatically, or document a workaround on this site. We’ve not accomplished that yet.

ps: If you’re able to work out the cause, a fix or workaround - that would be greatly appreciated. If you can write it up for this site I’ll move it to our documentation section happily.

1 Like

If you’re able to work out the cause, a fix or workaround […]

Sorry, I’m not a software developer, just a simple software user.

Is there at least a command for the terminal, so that the screensaver-window appears to make the configuration?

The command you’re looking for is


but that may ‘suffer’ the same problem that occurs when you try and open it via menu, ie. you’ll see only the crash I believe.

If it crashes, you’ll can edit ~/.xscreensaver directly using a text editor.

Note: I just did that sequence twice; first time I got a crash; second time it worked flawlessly, and xscreensaver is opening flawlessly for me now on 22.10/kinetic even at menu. I’ve not worked out reliably how it’s fixed, thus why we don’t currently have documentation on resolving it.

1 Like

If I run xscreensaver-settings, then:

(xscreensaver-settings:1873): Pango-WARNING **: 14:17:09.553: Invalid UTF-8 string passed to pango_layout_set_text()

(xscreensaver-settings:1873): Pango-WARNING **: 14:17:09.559: Invalid UTF-8 string passed to pango_layout_set_text()
Segmentation fault (core dumped)

If it crashes, you’ll can edit ~/.xscreensaver directly using a text editor.

There is no ~/.xscreensaver.

Note: I just did that sequence twice

I did that three times. But I can imagine that only one time is necessary. After one time, one should be able to open it by the menu.

it worked flawlessly

Not in my case. The appearance is different than the other windows:

It is inconsistent, which usually implies at least to me, that I’m missing something in my understanding of what is going on, and I don’t yet know what that is.

I used two fresh 22.10 installs yesterday (one being a QA test install prior to release that was only used for post-install checks & another install made yesterday just for this purpose) and on both I got xscreensaver working within two commands… On further exploration one now segfaults/core-dumps just as your paste shows, but the other still works perfectly & responds as I’d want it to.

I interacted briefly with @Leokolb who expressed getting the ~same results.

On both my boxes I had ~/.xscreensaver created (automatically) when the screensaver was working, the box that still works still has it.

I’ll provide a pastebinit copy of one which possibly is default, though I can’t recall if that was changed.

Sorry, currently I have no answers, as I’m missing something that explains the inconsistent results I’ve gotten thus far (I’m also lacking time, just as we all are!)


The easiest way I have of getting it working (I alluded to it in last post on this thread) is adding a


with a valid config. My attempts at creating a empty one didn’t help (ie. touch), but adding a valid file seemed to always work. My prior comment has a link to a pastebin link of one from a Lubuntu 22.10 install, but I tested it using various including .xscreensaver files grabbed from nearby Debian installs too, and older Ubuntu/Lubuntu installs.

@ralf3u If your xscreensaver still isn’t working, I suggest you try adding a valid ~/.xscreensaver, and let me know if it works for you, and continues to work over a few reboots. If I get some other responses of it always working (and not just some of the time, I want it reliable!) I’ll write up a quick page here for 22.10 users.

Link for ~/.xscreensaver provided in last comment.

1 Like

Thanks - that updated .xscreensaver file has fixed things for me (I’m not the OP, but had the same problem).

My system had a version of .xscreensaver that had been created by xscreensaver-demo 5.42. You can see the previous file Ubuntu Pastebin


$ xscreensaver-settings

$ sudo dmesg
[ 3260.216912] xscreensaver-se[3819]: segfault at 0 ip 00007f9206f909aa sp 00007ffdca542ae8 error 4 in[7f9206e22000+179000] likely on CPU 1 (core 1, socket 0)                                                               
[ 3260.216933] Code: 8b 04 82 29 c8 c3 66 2e 0f 1f 84 00 00 00 00 00 f3 0f 1e fa 89 f1 89 f8 48 83 e1 3f 48 83 e0 3f 83 f9 30 77 3b 83 f8 30 77 36 <f3> 0f 6f 0f f3 0f 6f 16 66 0f ef c0 66 0f 74 c1 66 0f 74 ca 66 0f

A fix is to run:
$ strace xscreensaver-settings

It’s probably a race condition.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.