Screen rotation confused

Hi everyone. When I turn on my laptop with Lubuntu, my screen rotate to right. After loggin I see same. I did open monitor settings and saw Rotation: none. After I set left, my screen stay good. But every power on my laptop my screen stay rotate right before I loggin(enter with password). What the problem? What can I do?

My laptop is digma eve 10 a200 es1052ew. Lubuntu 22.04 LTS (Jammy Jellyfish)

Are your monitor setting similar to these.
In the rotation box is it set to none.

After you make any changes click the Apply icon and then click the Save icon to save the changed settings.

2 Likes

You didnt understand me.
I know about settings of rotation. My rotation now set left. If I do NONE, then my screen will be turn rigth.

My NONE = right…
And I think Matrix confused If None = right, left = normal…

You might be using “Apply” rather than “Save” when you set the rotation to fix your screen. Contrary to how Windows works, in Lubuntu, “Apply” only sets your settings temporarily, so if you use “Apply” and then “Close”, your settings will be lost even if they appear to be working at the moment. If you use “Save”, that should get it to stick.

In the event that this doesn’t work, or you were using “Save” all along, try these instructions: Kubuntu sddm rotated login screen (20.04) - Ask Ubuntu I know it says that it’s for Kubuntu, but Kubuntu and Lubuntu both use SDDM, so the procedure should be the same.

2 Likes

Thanks for the link! Okay, screen login now left(normal), but start of the system before login keep stay as right… And attention! My width 1200, and height 1920 that good for right or left rotations, but normal is 1920x1080, if I change my WxH to 1920x1200, well, my screen is broken. I WANT NORMAL ROTATION WITH 1920x1080. I don want right rotation as default with 1200x1920 and change this to left for normal…

Do you know if you are using the intel Xorg driver or modesetting driver? If the former, there is a setting you could try.

driver i915 (Xorg, if I understand). Where I can find start settings for the randr?

i mean xrandr, there is DSI-1, 1920x1200 left

I was thinking more of
/usr/share/X11/xorg.conf.d

Inside something like 20-intel.conf or maybe inside one of the other files,
you can set some options
e.g

Section "Device"
  #Identifier  "IntelBuiltin"
  Identifier  "Intel Graphics"

Option "HWRotation" "false"
EndSection

That option turns off hardware rotation

“… and force the use of software, but GPU accelerated where possible…”

(ref)

There’s no file like /intel/ but my processor is Intel Atom x5-z8350…
And no one file have Section “Device” with identifier “Intel Graphics” or Graphics totaly…

Open a terminal. If you enter

dpkg -l | grep intel

and see something like this;

ii xserver-xorg-video-intel 2:2.99.917+git20210115-1

It means you have the package.

You may be tempted to add /usr/share/X11/xorg.conf.d/20-intel.conf
But at this point it gets a bit scary because you are messing with drivers and might not get a workable screen.

So, I would recommend you backup your partition before you do this. (e.g CloneZilla usb). This way if anything goes wrong, you can always restore your old partition and boot.

Also, I left out an important line in my last post, namely;
Driver "intel"

Here is my 20-intel-conf for my intel machine;

Section "Device"
  #Identifier  "IntelBuiltin"
  Identifier  "Intel Graphics"

  Driver      "intel"
#	Option      "DRI"    "3"
#	Option      "AccelMethod"  "glamor"
#	Option      "AccelMethod"  "uxa"

	Option      "AccelMethod"  "sna"
	Option      "TearFree"    "true"
#	tearfree is recommend for sna accel

	Option		"NonSense"	"true"

EndSection

You will see that I added a “NonSense” option.
If you successfully boot, and

less /var/log/Xorg.0.log

and search for NonSense
/NonSense

and see
..(WW) intel(0): Option "NonSense" is not used

This means that the config file was loaded.
You can then try out that option mentioned before.

2 Likes

Yes, I have it. Thanks you, I’ll try to do with that something later :slight_smile:

1 Like