Screen freeze on 18.04.5 Toshiba Equiuum

Hi, I’m using Lubuntu 18.4.04 on a Toshiba Equiuum A200. Every session the screen freezes and even the mouse doesn’t respond. Has anyone else had this? Is there a fix? Thanks in advance

When this happens can you use the likes of CtrlAltF4 to get to a virtual terminal? Is the drive light on or flashing at an extremely high rate?

From your description, I’d be more suspicious of hardware issues. Have you booted live media and run a memory test? Rather than let it finish once, I’d let it run overnight, even days.

If i have random freezes (where I can’t switch to text terminal to explore as per @wxl’s suggestion, or can’t even use SysRq keys to cause clean shutdown) and there wasn’t a recent software update (you mention 18.04.4 so you’re potentially months behind on updates anyway) I tend to check hardware using a live system that doesn’t have my modified config/settings.

You can use any live system, but I tend to use a different system to what I have installed by preference; if it’s another Ubuntu - a very different release anyway with different stack; 18.04.4 means you could be using the GA/general stack meaning the 4.15 kernel; or EOL 5.3 kernel if using HWE; when you upgrade to 18.04.5 you’ll bump to supported 5.4 kernel; use uname -r to see your kernel.

If it’s stable for hours on the live system, that does point more weight on a config or other problem on your installed system. If it’s unstable on the live system, that’s confirmation (esp. if different software stack was used) of hardware. I’d then open it up & look at the motherboard (cap-scan (look for swollen capacitors on board; they usually cause freezes and rarely reboots becoming more of an issue as they worsen), PSU check etc… but that’s more technical).

Is there a pattern that causes it? PSU (power supply) issues are somewhat predictable, fans running due to warmth, disk spinning etc - ie. mechanical motors drawing the power & insufficient for other parts of the circuitry and thus lockup…)

Anyway - my 2c is check your hardware… (and when it’s reliable, perform your upgrades)

2 Likes

Well I have had a sold state drive installed. Could that be the issue?

Haven’t noticed the drive light flashing. Will try CTL, Alt, F4 next time to see if that works

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

@alg when you mark something as a solution, it automatically closes the topic. Since what you marked as a solution isn’t really a solution but really troubleshooting information, I just unmarked it as such and re-opened the topic.

That said, is the problem solved? If so, please let us know what you did so we can actually have a good solution should anyone else have a similar problem.

No problem not solved yet, please leave open. Apologies

Freezed (froze?) Today. No flashing of drive light and ctrl/ alt/ F4 dies not respond.

Just checked version and it’s 18.4.05 with no additionalupdates, sec patches needed (up to date I assume)

Ok, well, that’s a halted system all right. So the drive light was not even lit, correct? Have you considered running a memory test?

Yes, drive light not lit. mHow long do I run mem test?

What am I looking for on memtest? Is there an error it would show up or do I just runn and let it self rectifyt?

All upgrades are current. Its actually 18.4.05 no 04 Appologies.

Ubuntu releases are year.month, where 2018-April release is 18.04, with a point release showing the update (.5 is the latest for Ubuntu 18.04 or flavor, .7 the latest for a 16.04 etc).

If it reports 18.4.05 - I’d be suspicious that something is very wrong (corrupted) with the system; as that’s an invalid release; see https://lubuntu.me/bionic-5-released/

As for a memory test:

If I have a new system, or a system that I’m not sure if I should trust, I generally leave it run at least a day (usually two if I want to trust it). If it’s a system that I already know, and hasn’t given me any problems, I usually only let it run overnight (assuming it completes a number of times without any issue).

Error lines are usually pretty evident, red line(s) of text, eg. look at hardware - Memtest86: Has my RAM gone bad? - Ask Ubuntu for a picture of a bad screen. You should not see any red line(s).

1 Like

Just ram metest, left it on all day. 10 passes, no red lines. Does that mean I need to be looking elswhere?

Ran memtest, no error reports, red lines etc. 10 passes in total. Is the fault elsewhere?

From your description RAM looks good, further if the machine operated that all day, it also includes an indication of some hardware stability (ie. a lock up because of swollen capacitors would stop ram testing; RAM testing isn’t high-stress but it’s still testing)

You mention mouse freezing, and inability to switch to text terminal (via CtrlAltF4)… I’d usually try CtrlAltF5 next out of habit… but that’s just me.

Next, if you have openssh-server installed & running, I’d try and login remotely… You likely won’t have this installed, and I’d likely not add it just for this test.

I’d then try using SysRq keys to see if the kernel is still working normally, and it’s not just the GUI/display (which could be graphics or a number of things) that has frozen… Given you’ve currently lost control of the box at this point, I’d probably just use a common REISUB command to see if it reboots…

If Alt+SysRq REISUB causes a reboot, that is proof the linux kernel is still running normally, it maybe just something graphics related and the display is frozen (you can’t see the continued operation of the machine even)

If kernel is still operating (ie. box rebooted when given B command), I’d next try logging in via terminal, and running a script that plays something via audio (paplay command maybe) looking to see if OS is working correctly, just the display isn’t… I’d also likely add openssh-server & try it remotely (it’ll be easier than the frozen screen)… But these are assuming SysRq commands to reboot actually worked (and box rebooted).

FYI: I used the wikipedia page as reference to SysRq kernel commands as it’s easy to find when needed and you’re limited to your phone… It appears at the top of search lists and is pretty good

2 Likes

I have experienced similar issues in Lubuntu 18.04. Sometimes PCmanFM (file manager) freezes, I then kill the process and all the icons from the desktop disappear until the next restart. But this is not such a big issue for me. Regarding the entire computer freezing I just had it I believe twice but all those cases were following the launch of GNOME MPV in cases when I was going to watch a movie, that issue was completely solved by installing VLC Media player on my computer.

The 18.4.05 version seems suspicious to me as well, I am not a computer pro but I assume that @alg switched off his computer multiple times in an unregular way following the freezes (with the power button). By simple logic those unregular switch offs surely corrupted some system files, so in my opinion the best way to solve this would be to back up every data on his PC to an external drive and then reinstall the entire operating system, with the iso file to be downloaded via torrent from the lubuntu.me website and prior installation an error check should be necessary to make sure nothing is corrupted in the installation files. And the drive of the PC should be formated in my opinion during the fresh installation. But as I am not a computer pro, @alg please wait for the response of @guiverc before doing anything, this is just my opinion on how this issue could be solved.

1 Like