Refresh Rate Mismatch

Hello everyone. I recently noticed that the refresh rate in the monitor settings is shown as 60.0197Hz but my monitor expects it to be 60Hz. This has been causing horrid flicker that causes increased eyestrain over time. I found that executing:

xrandr -r 60

from the terminal fixes the issue until I log out. When I log in again, the refresh rate reverts to that horrid 60.0197Hz and I have to repeat the process. Is there some way I can fix this so I don’t have to keep executing that command after logging in?

What version of Lubuntu are you using?

I am using version 20.04.1 and I keep it up-to-date whenever an update is available for it.

There are a bunch of different solutions on this page:

You can try this, first.

Open the start menu > preferences > LXQT preferences > Session Settings > Auto Start button on the left.

From there, click Add and then copy/paste the command and give it a name. Make sure to save it. Reboot to see if it takes effect. If it doesn’t, you then have a script option (and can be started that same way) which can be done any number of ways as indicated at the link above.

That should get you sorted - but I’ve never actually needed to try it in person.

1 Like

It appears to be working. I ended up creating a new autostart entry with the command:

xrandr --output VGA-0 --refresh 60

Thanks for your help. :smiley:

3 Likes

Thank you for confirming what worked. So many folks don’t do that online.

It should also be noted that this solution is very much a per-user fix. If you create other users that would be logged into the desktop, you’ll have to apply that solution for those accounts as well. Other than that, it should just keep on working for the foreseeable future.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.