Questions about upgrade

I need to upgrade from Lubuntu 14.04.5 LTS to the latest version of the same. But I’m not a tech guy and I have no one to help me. I have no idea how to do this, and I have many many questions.

My first question is: if I install the new system on the same hard drive, is my data at risk and how can I protect it? Ideally, I would start with a fresh clean hard drive, but I’m not able to do that at this time.

14.04 is unsupported and newer versions are completely different so an upgrade would be unsupported. I would advise backing up personal data and doing a fresh install of 19.10.

The upgrade paths from 14.04 LTS were to

  • 14.10 (ie. off the LTS path), or to
  • 16.04 LTS.
    Both of these paths are gone because both are now EOL (end-of-life). FYI: Lubuntu releases use a year.month format so 14.04 means you have/had the 2014-April release which had 3 years of supported life, reaching EOL 2017-April

Lubuntu up to 18.04 LTS used the LXDE desktop, and Lubuntu 18.04 LTS is the only release that is still supported using that desktop, so a re-install of that release is possible.

If you want to go this way (stay with LXDE), I’d recommend backing up your data of course, validate & boot 18.04 install media; install using “Something-else” using your existing partitions ensuring you don’t have format selected. The installer will note your installed packages, erase system directories, install system, add-back your additional packages (if available in 18.04) without touching any of your user files unless you had the ‘format’ box checked.

The same mentioned for 18.04 LTS can also be used with 19.10 (except ‘Something-else’ is called “Manual Partitioning”), however its results won’t likely be as clean as a re-install and restore of personal data as wxl suggested.

The primary benefit of Lubuntu 19.10 (even though a normal cycle with only 9 month life) is it will allow easy upgrade to Lubuntu 20.04 LTS when available; the 18.04 option lacks that. It’s also more modern, is what the current Lubuntu manual is geared for (https://manual.lubuntu.me/) and other secondary benefits too…

If your box/machine is x86 (32-bit) only however, Lubuntu 18.04 LTS is your only option.

1 Like

Some good information there. Thanks. After talking to others, I’ve determined that I do want a new hard drive. I found out that they’ve come down in price (I thought it was going to take a bundle of money), so I’ll be able do that.

I think my machine is 32-bit, but I’m not sure. How do I find out?

Once that’s done, I will still need help installing the operating system, because as I’ve said, I have no idea how to do that. I’ve perused the manual and some of it is hard for me to understand.

1 Like

I would try lscpu which is read as list cpu.

For my box I see

guiverc@d960-ubu2:/de2900/lan/unix$   lscpu
Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
...

where the architecture refers to what OS is installed (x86_64 or amd64 being 64-bit x86), the next line tells you my cpu can run both 32-bit and 64-bit x86 code.

(FYI: my cpu is intel, but because AMD created the 64-bit processor that could also run older x86 32-bit code, it’s called amd64 regardless of maker)

However on an older x86 only box I see

Architecture:                    i686
CPU op-mode(s):                  32-bit
...

where the architecture being run is i686 (it’s a 2005 dell laptop where i686 is an indicator of features of 32-bit x86 cpu), the second line tells me the cpu will only run 32-bit code.

To install Lubuntu, first you need to decide on a release, which requires that we know what CPU you are using; hopefully what I’ve described will tell you, or post details here and we can confirm (or help with any problems you have; eg. my x86 box is running Lubuntu 18.04, my amd64 box is running Lubuntu 20.04, so whilst I’d expect your 14.04 to reveal detail like the lines I copy/pasted; I haven’t seen a 14.04’s result in many years.

The best guide for installs is probably

https://manual.lubuntu.me/stable/1/Installing_lubuntu.html

but images/screens will match the latest stable release; ie. Lubuntu 19.10 which is what I’d install if using a amd64/64-bit processor. You can’t install 19.10 on a 32-bit only cpu though.

1 Like

That’s what I usually do. Get a replacement drive and an external drive housing. You’ll have to get a housing that matches the existing drive’s size & interface. (You said that you think your cpu is 32-bit. In that case the drive might be SATA-1. You’ll have to make sure the external case is compatible with that drive.).

I install the new OS to the new drive (installed in the old laptop), and then connect the old drive (now in the external housing) via USB, and copy my data. I also backup before doing all this. (At least copy my home folder to a backup drive in another external housing. Maybe the one from the previous OS install.). But, you should be fairly safe just removing the existing drive to an external housing.

Like you said, drives are so cheap. I just bought a 500gb SATA-3 for $30 USD (Western Digital WD5000LPLX on Amazon).

If your CPU is 32-bit, you’ll have to find a different distro. Peppermint struck me as very similar to Lubuntu. It emphasizes network apps and cloud computing. But, you can install local apps like any other distro (and delete the network apps it comes with). Something about it’s look and feel reminded me of Lubuntu’s original LXDE desktop.

I’ve been using MX Linux. It has 32-bit versions too. I just got a new laptop and am planning to switch from MX to Peppermint just to use it for a few months, and be familiar with it. My new laptop is fairly powerful (Ryzen 3. Benchmark is 4570 compared to my budget Toshiba’s Celeron which is 960.). I’m really tempted to run KDE Neon. It’s a bit heavier than Lubuntu/Peppermint/MX. But, I’ve always been attracted to KDE. With the power of this new laptop… I’m tempted. But, I feel like I owe it to Peppermint to run it for 6-12 months. I intended to go to it when I went to MX.

So many distros… so little time.

I got the hard drive, and downloaded the file onto a USB device. I hooked up the new hard drive and turned on the machine and… nothing. What do I do next?

Did you check the hashes of the ISO? If that fails, you’d want to check the hashes of the USB, too, but that’s a little more advanced.

No, how do I do that?

It’s described in the manual but tl;dr sha256sum lubuntu-19.10-desktop-amd64.iso should return 761c4603f689b1a109d67bde3f2ca0bcc750ce973ac8c1a8e98ca188bbc3e760 *lubuntu-19.10-desktop-amd64.iso.

To verify your write to media, the easiest way is using the “Check disk for defects” option found near the top of page https://manual.lubuntu.me/stable/1/1.3/installation.html

The generic Ubuntu help page for this is https://help.ubuntu.com/community/Installation/CDIntegrityCheck but note disk/disc or CD refers to your installation media regardless of what media it’s stored on, eg. cd/dvd/hdd/ssd/thumb-drive or anything else (eg. it can still be used if you boot from device over a network)

In my experience I’ve had more troubles with writing to thumb-drives, than bad downloads, but some download methods do the verify post-download (eg. zsync I usually use) so I tend to trust that unless I have problems (then I check everything!)

Later addition.
If I can’t boot the media on one box; I tend to boot it on another boot and perform the check there. If it fails to boot, or fails the ‘Check disc for defects’ on the second box I assume it’s bad and return to the prior md5sum/sha256sum check @wxl mentioned.

Agree, but I didn’t mention this because it sounded like it didn’t boot at all.

1 Like

It says “No such file or directory”. I’m attempting to follow the manual, but my level of understanding is insufficient.

It may help if you copy/pasted the command & output into your post. My understanding was you executed

where the error message “No such file or directory” would imply your present/current directory isn’t where the file was downloaded to. You could adjust it to something like

sha256sum ~/Downloads/lubuntu-19.10-desktop-amd64.iso

assuming you download the ISO file to your ~/Downloads/ folder (~ is a shorthand for /home/guiverc/ in my case; or /home/user/ if your username was “user”). You can change the path part of the filename ("~/Downloads/") to point to wherever you downloaded the ISO.

Sorry if I misunderstood what you were replying to.

No, I downloaded it to a USB device. 18.04 32-bit.

If you think that is all you needed to make a bootable installation image on your USB, that’s where your problem lies.

The ISO is essentially an image of an entire storage device, which means it includes files inside of it, as well as the filesystem, as well as things outside of the filesystem, such as the partition table, etc. Think about it like this: the filesystem itself (which can be of many types) is invisible to you when browsing the files inside of it with a file manager. And you certainly never browse your actual partition table. But all of that stuff needs to be there to boot a device (like your hard drive) regardless of the operating system.

Inside the context of a filesystem, though, the ISO is nothing more than a regular file. To download it to the USB device, the device would already need to have a filesystem (i.e. it’s formatted) and a partition table. Doing this essentially copies the file— not its contents— to the device. It’s similar to a zipped file. Just because you copy a zipped file somewhere doesn’t mean its contents are opened up onto that location. Instead you use a special tool to “unzip” the file.

What you need to do is essentially open up the ISO onto the device. You do this with a bit by bit copy tool. There are many tools for this as described in the manual. Pick one appropriate to your situation, download the file again but NOT to the USB, then use one of those tools to do the bit by bit copy to the USB device.

Oh, so you are 32 bit only? Bummer. That means you are most definitely not on 19.10 as we were saying since there is no i386 version (no Ubuntu flavor does i386 images at all anymore and haven’t for a while). So you will need to do the hash against the correct filename, too :wink: When you do (and, yes, make sure you get the 18.04 .3 version) , you should get:

02622bd2f2a0f19fc300f5784a13db237c67864619f6fa2a4a270a4b71751726 *lubuntu-18.04.3-desktop-i386.iso

What that does is confirm you have no download errors.

Then when you succeed there and successfully boot, select the “Check disc for defects” option and that will check for copy errors. If you can’t boot at all, but the hashes check out, I would take that as a sign that you have a copy error!

I know it seems crazy but a single bit of difference can lead to all sorts of potential problems that are nearly impossible to diagnose and resolve. And yes, I’ve had to do this for Windows ISOs, too. Download and copy errors are just part of computing.

1 Like

Thank you for explaining. I appreciate your time and patience. I can’t read the manual; it’s written in technical jargon. I need the Dummies version. I don’t know anything about this stuff. I’m willing to learn, but you really do have to explain it to me as if to a 5-year-old.

I used Startup Disk Creator to copy the download to the device. I think I did it right. It seemed to have worked. Then when booting up the new hard drive with the device inserted, I get this:

Missing parameter in configuration file. Keyword: path
gfxboot.c32: not a COM32R image.
boot:
gfxboot.c32: not a COM32R image.
boot:
gfxboot.c32: not a COM32R image.
boot:

The manual says, "it may boot into the image right away, or you might need to press a key at startup for boot options. "

So you will need to do the hash against the correct filename, too

That’s not mentioned in the manual. How do I do that?

I’m like you. Stick with it. I’ve dabbled with Linux since when we ftp’d 21(?) 1.44mb diskette images. There was no desktop. Later on, I almost always had a second box running Linux (Red Hat, back then). I tried going Linux-only a few times over the years. Finally I made it happen in 2014 before Win 10 was release (I was readng where that was going, and thought it was time to suffer through change.). It truly astounds me how, after all this time, I still find linux incomprehensible. I’ve got notes of key things to know. I do ok. But, I can’t comprehend how someone can know all the stuff these people know. I can just barely keep my acquired notes in my mind. (And I’m one of those people who downloaded 21 diskettes back then.).

Stick with it. Keep exposing yourself to it. It’s like learning a new language. Keep plugging away, take notes, set aside time to try something new. (Did you ever run Linux in a Virtual Box on Windows? I assume you’re coming from Windows. You can install a distro in a Virtual Box and play with it that way.).

2 Likes

The hashing is discussed here but assuming that you downloaded the ISO (this is the right one, just to be sure) to the default location (the Downloads folder in your home folder), you would do:

sha256sum ~/Downloads/lubuntu-18.04.3-desktop-i386.iso

and that would return

02622bd2f2a0f19fc300f5784a13db237c67864619f6fa2a4a270a4b71751726

Now normally seeing what you’re seeing I would say “check the hashes, you’ve got a download and/or copy error,” but I thought to do a little search and it seems you have a problem I have not encountered, um, ever.

I guess that if you use a really old version of Ubuntu to make a live media of a new one, something about it doesn’t work right. I understand it’s related to the syslinux version (this is the boot screen we all think is GRUB on BIOS-driven boots) being incompatible but don’t entirely understand the mechanism.

Nevermind all that, though. The solution in your case is to hit the Tab key at the boot: prompt and then pick one of the options, most likely live.

1 Like