Question regarding xscreensaver process

Hi all, :wave:

a happy and healthy New Year to all of you. :heartpulse:

I´ve got a question referring to xscreensaver:

I have disabled xscreensaver with the command: xscreensaver-demo. The GUI gives me the option

“Display Modes —> Mode —> Disable Screen Saver”

This works as desired, but there still seems to be some process connected to xscreensaver running:

ps aux | grep xscreensaver
rosika      1466  0.0  0.1  16568  4876 ?        S    12:21   0:01 /usr/bin/xscreensaver -no-splash

Does anybody know why that is and if it´s safe to kill that process (if not needed) :question:

Many thanks in advance and many greetings.
Rosika :slightly_smiling_face:

P.S.:

I´m running Lubuntu 20.04.3 LTS

1 Like

I just happened to run across this on another topic, goto

Preferences > LXQt settings > Session Settings >
Autostart > LXQt Autostart > XScreenSaver >
Edit > Command
and blank out the command “xscreensaver -no-splash”.

1 Like

Yes it’s safe to kill the process; however that doesn’t mean it doesn’t have consequences.

If you lock your system (with it killed), you’ll get an error message instead of the intended lock procedure… ie.

An error occurred starting screensaver. Action ‘activate’ failed.
Ensure you have xscreensaver installed and running.

as xscreensaver performs the LOCK function. The initial login/greeter is performed by the DM (display manager) but it doesn’t handle the locked session.

1 Like

Hello again to all of you, :wave:

thanks so much for your replies. :heart:

@humpty:

Thanks for the suggestion.
As a matter of fact I already looked up the autostart settings but it didn´t occur to me that the settings can be edited. :blush:

Here are the settings as they are at present:

Whe you mentioned

do you mean to erase the command (“Befehl” in the screenshot) altogether?

And if I do so there still seems to be be a potential issue as @guiverc pointed out.

But at least I know how to do it now thanks to your kind help.

Thank you very much again and many greetings from Rosika :slightly_smiling_face:

@guiverc:

Hi Chris,

thanks for the warning.

This is something didn´t know I have to admit. :blush:
Thanks for the clarification.

Considering all the facts I think it might be best to leave things as they are right now.
I was just wondering why a process referring to xscreensaver was running but that´s clear now.

Many thanks again for your kind help …

…and many greetings
Rosika :slightly_smiling_face:

1 Like

oh, I didn’t know that. (i never lock my screen).
Yes, you shouldn’t touch it then.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.